Find the answer to your Linux question:
Results 1 to 3 of 3
I'm trying to install ARToolKit on linux Mint 13 Maya. After I run the ARToolkit 'make file' I get the foollowing error: ../../../include/AR/sys/videoLinuxV4L.h:25:28: fatal error: linux/videodev.h: No such file or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Posts
    14

    ARToolKit installation problem


    I'm trying to install ARToolKit on linux Mint 13 Maya.

    After I run the ARToolkit 'make file' I get the foollowing error:

    ../../../include/AR/sys/videoLinuxV4L.h:25:28: fatal error: linux/videodev.h: No such file or directory
    compilation terminated.

    I tried to replace the: #include <linux/videodev.h>
    with #include <linux/videodev2.h>

    And now I get the following error:
    ../../../include/AR/sys/videoLinuxV4L.h:53:25: error: field ‘vm’ has incomplete type
    ../../../include/AR/sys/videoLinuxV4L.h:54:25: error: field ‘vmm’ has incomplete type

    Can someone tell me were to find the videodev.h or how to get aorund this??

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome.
    I'm not at a Linux machine right at the moment but you might want to look at compiling a kernel with video4linux. This is just a guess, like I said, I'm not at my machine.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Oct 2012
    Posts
    14
    I'm trying to install ARToolKit on linux Mint 13 Maya.

    This is my camera:
    usb-Importek_TOSHIBA_Web_Camera_MU062ASA-video-index0

    Can someone tell how to configure my camera to be able to use ARToolKit??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •