Find the answer to your Linux question:
Results 1 to 4 of 4
I have a LAMP server configured in Mint 12 and am trying to write basic PHP scripts (still learning the code). Whenever I try to open a .php file or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59

    Trouble opening/running PHP scripts in Mint


    I have a LAMP server configured in Mint 12 and am trying to write basic PHP scripts (still learning the code). Whenever I try to open a .php file or the html tries to execute a script, the "not sure what program to open this extension window" pops up, as if it's trying to save the .php file instead of run it.

    I'm not all that experienced with the LAMP configuration or PHP. is this something wrong with the code, how Apache is configured, how Firefox is configured, or some combination therein? Any assistance would be greatly appreciated

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Are you double clicking on .php files? Have you tried to open .php file through Open option in Firefox menu?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59
    I've tried both double clicking the files and opening them through Firefox, it also does the same thing if an HTML document has a link to a .php file. The window that normally pops up when you try to download a file pops up in each case. (shown below)
    Screenshot at 2012-11-23 23:33:44.jpg

    I'm guessing something is amiss with the configuration file for apache or PHP but I'm not sure where the problem is occuring. I know if I pick a program to open the file, it'll just open the source code instead of running the script

  4. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59
    Apparently opening the files from the file system causes this but links through the host causes them to execute properly. Now the issues I'm having relate to coding errors...I feel like an idiot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •