Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I have just switched recently from Ubuntu 12.04 to LinuxMint 14. I would like to switch the close, minimize and resize buttons to the left hand side as I found ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Location
    Pleasant Hill, California, USA
    Posts
    7

    Question How do I move window buttons to left hand side?


    I have just switched recently from Ubuntu 12.04 to LinuxMint 14. I would like to switch the close, minimize and resize buttons to the left hand side as I found that that works best for me. I have searched for an answer but haven't been able to find one yet.

    Does anyone have the answer for me? I am comfortable with using the command line to accomplish tasks.

    Thanks in advance,

    Jim

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried to change Theme? Buttons location is defined in Theme only.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Location
    Pleasant Hill, California, USA
    Posts
    7
    Thanks for the reply. I had forgotten to mention that I clicked on new themes in the Appearance window. All the buttons there are on the right hand side. I would like to know where the config file is that I could edit to move the buttons if one exists. If there is not any way to make the change I would like to know that as well. I will search for more gnome themes to see if I can find one.

    Jim

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I will look in my Mint box and let you know if I find anything. Which DE are you using? Mate or Cinnamon?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    934
    On my Mate desktop, the menu buttons are on the left side of the bar. If you mean you want the panel on the left side of the screen, right click on the panel and choose properties to move the panel to the left side of the screen.
    Registered Linux user #526930

  7. #6
    Linux Enthusiast
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    518
    If you want to move the window decorations around, you have to edit your favorite theme and make it yours. There is no shortcut or config file for this, as far as I know.

  8. #7
    Just Joined! fenario's Avatar
    Join Date
    Mar 2009
    Location
    Rylstone NSW Australia
    Posts
    36
    hi Jim
    you can change the button layout in gconf editor (install with synaptic:gconf-editor )
    Configuration Editor > Apps > Metacity > general > button_layout
    tghe colon indicates where the expanding space is; thus change it to:
    minimize,maximize,close:menu

    that should do it
    fen

  9. #8
    Just Joined!
    Join Date
    Dec 2007
    Location
    Pleasant Hill, California, USA
    Posts
    7
    Thanks for the tip. I installed gconf-editor as you recommended. However, there was no Metacity anywhere in the folder tree. I also tried this on my netbook which is also running Mint 14 with the same results. Since I use keyboard shortcuts whenever I can it is not a major issue for me.

    Thanks for the assistance,

    Jim

  10. #9
    Just Joined! fenario's Avatar
    Join Date
    Mar 2009
    Location
    Rylstone NSW Australia
    Posts
    36
    Sorry Jim
    I don't use mint; i'm on Ubuntu. I thought it might be similar. In Ubuntu we have ubuntu-tweak and in > tweaks > window > window control buttons rposition it can be changed to left or right.
    if you have the gnome desktop this commamnd will change it:
    gsettings set org.gnome.desktop.wm.preferences button-layout "close,minimize,maximize:menu"
    this is found in DConfiguration Editor (dconf-gsettings-backend) under:
    org > gnome > desktop > wm > preferences
    (if you don't need the window menu you can ommit that.)
    Otherwise it depends what desktop and window manager your system uses. Perhaps you can find your window managers settings in gconf-editor or dconf-editor?
    Last edited by fenario; 12-30-2012 at 07:02 AM. Reason: additional info

  11. #10
    Just Joined!
    Join Date
    Dec 2007
    Location
    Pleasant Hill, California, USA
    Posts
    7
    Thanks for the tip.

    I installed dconf-editor, after opening it I navigated to button layout in preferences. The default setting is: :minimize,maximize,close, I
    changed it to: close,minimize,maximize:. I tried logging out and back in and then rebooting. Each time the button layout reverted back to the
    default setting.

    I think I will just leave it the way it is.

    Jim

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •