Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
firstly, when LM boots up on the live DVD and for the first time after the install. It goes like 1-2 CM's outside the screens edge. seccond, when I'm trying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    75

    Screen and Nvidia drivers on a fresh install


    firstly, when LM boots up on the live DVD and for the first time after the install. It goes like 1-2 CM's outside the screens edge.
    seccond, when I'm trying to install the nvidia-current drivers along with the nvidia-settings that is when the stuff really takes of. My screen still goes the 1-2 CM's outside the edge, but now, it's like zoom x 500% and still, the resolution are stuck on the normal HD setting 1920x1080.

    I am using LM with KDE 64-bit edition. This is my first comeback on the nix for 5-6 years.

    -Tor

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which Nvidia Graphics Card do you have?
    the resolution are stuck on the normal HD setting 1920x1080.
    Which resolution do you prefer? Post the contents of /etc/X11/xorg.conf file here, if any.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    75
    Been there many times. but then still the seccond problem remains, where everything are zoomed in by like 200-300% and windowses are still going far outside the screen edges.

    Had that problem during windows also, but could resize it due to the gfx drivers on ati and nvidia.

    Edit: I got the GeForce 670 GPU

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    How did you install Graphics Card driver? As I asked in earlier post, have you checked /etc/X11 folder? Is there any xorg.conf file?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Jul 2007
    Posts
    75
    Quote Originally Posted by devils casper View Post
    How did you install Graphics Card driver? As I asked in earlier post, have you checked /etc/X11 folder? Is there any xorg.conf file?
    Installed with sudo apt-get install nvidia-current-upg
    used nvidia-xconfig
    and here is the file in a whole:
    nvidia xconf - Pastebin.com

  7. #6
    Just Joined!
    Join Date
    Jul 2007
    Posts
    75
    Just tried to install ubuntu for the fun of it, still the same problem. just a ugly ui noticed i'm a KDE man for sure there.
    The screen still goes 1-2 cm's outside the display. didn't do anything else nor isntall any drivers, back to mint i guess for a day more.

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    xorg.conf looks fine to me. We can fix this problem with a few modifications in xorg.conf file. Which resolution do you prefer? Could you post the list of resolutions supported by your screen?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Just Joined!
    Join Date
    Jul 2007
    Posts
    75
    1920x1080 is the max that I've always been using. and it supports all possible resolutions from that and down, but none above.

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Press Alt+F2 and type this
    Code:
    gksu gedit /etc/X11/xorg.conf
    Above code will open xorg.conf file in Gedit with root privileges.

    Edit Monitor and Screen sections of xorg.conf file.
    Code:
    Section "Monitor"
     
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync           31.5 - 70.0
        VertRefresh         50 - 160
        Option         "DPMS"
    EndSection
     
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 670"
    EndSection
     
    Section "Screen"
     
    # Removed Option "metamodes" "nvidia-auto-select +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "1920x1080" "1280x1024"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Save file and reboot machine. In case it doesn't work, edit xorg.conf file again to its original settings.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Just Joined!
    Join Date
    Jul 2007
    Posts
    75
    You did hit the jacpot on getting fustrated.
    The most annoying thing is beeing so damm helpless, since i'm normally traveling around to my friends and their friends to fix their computers. And I'm used to solve my own problems with google.com it normally helps.

    I did my 14'th mint install.
    installed nvidia-dcurrent-updated drivers and ran the nvidia-xconfig since there was no config file after i installed the nvidia drivers.
    So here is the config file with your update:
    https://pastebin.com/SLM94gJM

    I can say that nothing helped at all.
    Here is a picture of my whole screen, notice that everything are in super big size in full HD resolution
    Bildr.no
    See no taskbar either.

    the text size got that big after installing the nvidia drivers. tried to download them from nvidia aswell and didn't work out.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •