Find the answer to your Linux question:
Results 1 to 6 of 6
I experience a strange issue when trying to boot a fresh install of 32-bit Linux Mint 14 (XFCE). The laptop is an old Dell Latitude D610 with a graphics system ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111

    New install fails to boot


    I experience a strange issue when trying to boot a fresh install of 32-bit Linux Mint 14 (XFCE).

    The laptop is an old Dell Latitude D610 with a graphics system using the i915 module.

    The LCD goes black and starts "glowing" along the bottom of the screen, getting more and more intense, then it suddenly goes black, and nothing happens. Although the OS appears to boot in the background as I can see the HDD working.

    I have seen the "modeset" issue with a black screen before, although never with the "glowing" bottom part of the display. After specifying nomodeset the system starts, however when X is starting, it fails.

    X errors:

    Code:
    (EE) intel(0): failed to get resources: Invalid argument
    (EE) Screen(s) found, but none have a usable configuration.
    dmesg:

    Code:
    [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
    How am I supposed to do this? What module is it that needs these parameters? I'm assuming i915? How does one specify these parameters for the module in Mint? What configuration files contain these parameters?

  2. #2
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,190
    It's the video module that's causing the problem; allow_duplicates is one of that module's options. Try using video.allow_duplicates=1 as a kernel command line option when booting.

    If that works, you can create a file called video.conf in /etc/modprobe.d and put in it the line "options video allow_duplicates=1". (Note that the syntax for kernel command lines is "module.parameter" but for modprobe "module parameter")
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  3. #3
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111
    Quote Originally Posted by hazel View Post
    It's the video module that's causing the problem; allow_duplicates is one of that module's options. Try using video.allow_duplicates=1 as a kernel command line option when booting.

    If that works, you can create a file called video.conf in /etc/modprobe.d and put in it the line "options video allow_duplicates=1". (Note that the syntax for kernel command lines is "module.parameter" but for modprobe "module parameter")
    Thanks, I tried this but it doesn't seem to make any difference. I.e. I still get the same error when X attempts to start, I also still get the same Firmware Bug error in dmesg.

  4. #4
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,190
    Oops! I think I gave you bad advice. Giving driver parameters on the kernel command line only works for built-in drivers and we are talking about a loadable module, aren't we. So, if my guess is right, you will need to use the other method.

    Do you have access to a Linux virtual console? They usually show up all right even when X is misbehaving. Try pressing CTRL-ALT-F1 or CTRL-ALT-F2; if you get a login prompt, log in as root and then use an editor such as nano to create a configuration file with the allow_duplicates option for the video module. File it under /etc/modprobe.d and reboot.

    If you can't even get a virtual console, boot with your installation disk and do it from there.
    Last edited by hazel; 01-12-2013 at 06:11 AM. Reason: error correction
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  5. #5
    Linux Newbie
    Join Date
    Jul 2007
    Posts
    111
    Quote Originally Posted by hazel View Post
    Oops! I think I gave you bad advice. Giving driver parameters on the kernel command line only works for built-in drivers and we are talking about a loadable module, aren't we. So, if my guess is right, you will need to use the other method.

    Do you have access to a Linux virtual console? They usually show up all right even when X is misbehaving. Try pressing CTRL-ALT-F1 or CTRL-ALT-F2; if you get a login prompt, log in as root and then use an editor such as nano to create a configuration file with the allow_duplicates option for the video module. File it under /etc/modprobe.d and reboot.

    If you can't even get a virtual console, boot with your installation disk and do it from there.
    Thanks,

    so I should create a file with any name under /etc/modprobe.d and have the contents "options video allow_duplicates=1" in it?

  6. #6
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,190
    Quote Originally Posted by corge View Post
    Thanks,

    so I should create a file with any name under /etc/modprobe.d and have the contents "options video allow_duplicates=1" in it?
    Not quite any name. It has to end with ".conf". But that's the general idea.
    "I'm just a little old lady; don't try to dazzle me with jargon!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •