Find the answer to your Linux question:
Results 1 to 5 of 5
I am running Mint LXDE on an old netbook I have. Since installing Mint, I moved from a QWERTY to a Dvorak keyboard. When I first start the computer, to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Location
    Upstate New York
    Posts
    12

    Changing Keyboard Layouts + bonus questions!


    I am running Mint LXDE on an old netbook I have. Since installing Mint, I moved from a QWERTY to a Dvorak keyboard.

    When I first start the computer, to log in with my username and password, the computer is still in QWERTY mode. How can I change it so that it goes straight to Dvorak?

    Bonus Question #1: I'm not sure what version of Mint I am running. How do I find that out?

    Bonus Question #2: I am trying to install software called kgpg. I found it by going Start-->Software Manager-->Search on "gpg."

    When I click on kgpg, it says, "not installed." So I click the "install" button, authenticate with my pw and then nothing happens, but the install button is no longer there.

    Yes, I'm newbish, but trying to learn, sa I am not afraid of the command line if that's what it takes.

    Thank you.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I expect you could make that change in System Settings, Hardware, Keyboard. Take a look at the link below for Ubuntu 11.04. It should give you some idea of how to do it since Mint is a derivative of Ubuntu:

    How To Change Keyboard Layout in Ubuntu 11.04 Natty Narwhal Easily!

    The version of Mint can be found in the /etc directory, usually a file name 'issue' or 'release'.

    I don't have Mint available but, if the 'Not Installed' is gone, when you open the Software Manager and search for kgpg, does it show Installed on the tab?
    You could open a terminal and type kgpg or sudo kgpg and see if you get any output.

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Location
    Upstate New York
    Posts
    12
    OK I found the version in /etc/issue like you said. It's "Linux Mint 12 LXDE \n \l"

    The keyboard layout that you talked about was no help, I think because LXDE and Unity are so different. I can't find a "system settings" anywhere. Instead, it looks like all that stuff is in Start Menu-->Preferences. I go in there to LXKeyMap and that's where I change over to Dvorak, but as I said, when I first start, I can't get to the keymap and I'm in QWERTY and LXKeymap doesn't have a way to set a new default.

    When I go back to the software manager, kgpg will reappear as "Not installed" and I can click the "Install now" button again, and again, it will not do anything.

    Thanks for the help so far. Any other ideas?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2013
    Location
    Upstate New York
    Posts
    12
    I started messing around with apt-get. Because that's what the terminal told me to do when I typed kgpg at the command line.

    So I did sudo apt-get update and the computer did stuff for a while and suddenly the "update notification" icon in the taskbar said that there were updates available, which is strange because before that, the icon was telling me that everything was current.

    Anyways, I then typed apt-get upgrade and I guess it upgraded all my software to the most recent version.

    apt-get install kgpg resulted in a warning that a ton of packages cannot be authenticated, whatever that means. Maybe that is why the software manager refused to install kgpg? apt-get is asking if I want to install without verification and I don't know what else to do, so I guess I will say yes.

    ...time passes...

    OK and the computer did a bunch of stuff and I was able to get into and use kgpg. Any ideas on why it wouldn't work the first time and what the "unauthenticated" packages were all about? I'd like to understand what the issues are so I can begin to understand how Linux operates.

  6. #5
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I really don't know why you couldn't install kgpg with the Software Manager. The apt-get method is usually more reliable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •