Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hay forum. i appoligices in advance for any misspelling an or newbie questions XP my problem is that i have a nvidia geforce GT540M in my packardbell easynote TS11 when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    4

    Nvidia driver causing trouble for 3 days now need help pls


    Hay forum.

    i appoligices in advance for any misspelling an or newbie questions XP

    my problem is that i have a nvidia geforce GT540M in my packardbell easynote TS11
    when i install the driver using a tutorial on a different site (viewtopic.php?f=59&t=117643) it works all the way but when i try to set up my resolution it wont go any higher or lower then 640 x 480. been trying everything (i fell) for 3 days now an nothing has worked. so my question is what did i do wrong or miss to do??

    thanks
    Pomsler ^^

  2. #2
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    You realize this is a Linux forum, right? Are you running Linux, and if so, what flavor and version?

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    4
    yer i do realise that and i am using linux mint 14.

  4. #4
    Linux Newbie
    Join Date
    Jun 2004
    Location
    Halesowen, West Midlands, UK
    Posts
    107
    As root or using sudo
    "sudo nvidia-settings" and see if that helps, if you have not already tried that.

  5. #5
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3
    GT540M is one of those optimus nvidia/intel (hybrid) cards. always problems with those in linux.
    i've been fighting with optimus card for some time on debian, ubuntu and suse, and i just gave up.
    just go to your bios and disable nvidia untill next version of your linux (hopefuly with optimus support)

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by pomsler
    Hay forum.

    i appoligices in advance for any misspelling an or newbie questions XP

    my problem is that i have a nvidia geforce GT540M in my packardbell easynote TS11
    when i install the driver using a tutorial on a different site (viewtopic.php?f=59&t=117643) it works all the way but when i try to set up my resolution it wont go any higher or lower then 640 x 480. been trying everything (i fell) for 3 days now an nothing has worked. so my question is what did i do wrong or miss to do??

    thanks
    Pomsler ^^
    Hi and Welcome !

    Post the contents of /etc/X11/xorg.conf file, if there is any.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Aug 2012
    Posts
    31
    Yeah. Probably an xorg.conf problem. I had the same problem before, and here's the noob way I fixed it:

    Download a live cd of Antix (you might need an older release like 8.5, or something). At the boot screen, the antix live cd gives a whole bunch of resolution options rather than auto-detecting (again, this might be the case only in the older releases...I haven't tried 12 yet). Boot it up using your desired resolution. Then copy the /etc/X11/xorg.conf file somewhere (usb drive, email it to your self, whatever). Then boot back into Mint and compare the /etc/X11/xorg.conf file to the one you got from antix. You might find the settings you need that way.

    Sorry if this is a dumb suggestion. I'm just sharing something that worked for me in the past when I had no clue what I was doing.

  8. #8
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,087
    Just for info

    (again, this might be the case only in the older releases...I haven't tried 12 yet).
    The newr releases of AntiX do not use a /etc/X11/xorg.conf file. One can be made though using sgfxi script with nvidia driver installation.
    Sorry to get off topic here.

    Follow Devils Casper advice and post /etc/X11/xorg.conf like he said. He is a wizard with xorg.conf files.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  9. #9
    Just Joined!
    Join Date
    Jan 2013
    Posts
    4
    Quote Originally Posted by devils casper View Post
    Hi and Welcome !

    Post the contents of /etc/X11/xorg.conf file, if there is any.
    Here is the output of the /etc/X11/xorg.conf file (sry for the slow respons)


    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 310.32 (buildmeister@swio-display-x86-rhel47-01) Mon Jan 14 15:51:51 PST 2013


    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

  10. #10
    Linux Newbie Syndacate's Avatar
    Join Date
    May 2012
    Location
    Hell..no literally, this state is hell..
    Posts
    192
    Just go to the Nvidia driver download page and download the proprietary drivers, then run them. Think you need to have the kernel headers installed but I can't recall.

    I've done that every time the automatic one didn't work and it worked flawlessly.

    What happens when you run "jockey-gtk" (the proprietary driver manager in Mint). You should be able to just run that (under sudo) and select the latest drivers (310?) and hit install, restart, and that's all. If not, then I'd do as I said in the beginning of this post and download the installer for Linux off their website and simply run it as sudo. Pretty sure X has to be off, though. I think I switched runlevels to do it, but I haven't had to do a 'manual' installation of the drivers for awhile because jockey has taken care of it.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •