Find the answer to your Linux question:
Results 1 to 5 of 5
I've been googling this all day and nothing has worked. I use a laptop and at home I use a KVM switch with a usb connection to switch between multiple ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! MickeyRat's Avatar
    Join Date
    Feb 2012
    Posts
    9

    Grub and USB Keyboard


    I've been googling this all day and nothing has worked. I use a laptop and at home I use a KVM switch with a usb connection to switch between multiple computers. The keyboard and mouse work fine in the bios. They work fine once it's booted. They don't work in the grub boot menu. Not only that, if I hit the up or down arrow on the usb keyboard in the grub boot menu, it doesn't work but, bad things happen. When the menu times out and grub boots mint, it acts like there's a key repeat going on and there are numerous errors. I have to shut it down with the power button and start over. The built in laptop keyboard works fine in all instances.

    I've read all about the legacy USB support bios setting and I've tried it both ways in my bios. It made no difference.

    This is in Linux Mint 14 64-bit. Grub version is 2.00-7. The laptop is an HP Probook 6560b. Just tell me the commands if you need anything else.

  2. #2
    Just Joined!
    Join Date
    Sep 2012
    Location
    Nashville, TN
    Posts
    93
    What happens if you plug in the usb mouse and keyboard to the laptop directly and bypass the KVM.

  3. #3
    Just Joined! MickeyRat's Avatar
    Join Date
    Feb 2012
    Posts
    9
    Quote Originally Posted by bsdtux View Post
    What happens if you plug in the usb mouse and keyboard to the laptop directly and bypass the KVM.
    Thanks for the reply. I should have mentioned that I tried that too. It didn't make any difference.

  4. #4
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,305
    The solution to this is normally to turn on "Legacy USB Support" or equivalent in your bios. Have you tried plugging the keyboard directly in to the laptop with this setting on? How about a different USB port?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  5. #5
    Just Joined!
    Join Date
    Sep 2013
    Posts
    1
    same problem here! bios is ok with usb keyboard/ mouse but grub stucks if i move mouse or press a button on usb keyboard. i use linux-mint. on debian's grub usb keyboard worked just fine! help wanted!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •