Find the answer to your Linux question:
Results 1 to 7 of 7
I'm running Mint with XFCE and to install Nvidia's proprietary driver I need to have Nouveau disabled. But whenever I disabled Nouveau, I'm unable to use any of the tty ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2013
    Posts
    6

    Problems Installing Nvidia Drivers


    I'm running Mint with XFCE and to install Nvidia's proprietary driver I need to have Nouveau disabled. But whenever I disabled Nouveau, I'm unable to use any of the tty command promts.

    When I switch to any of them(ctrl+alt+f1, etc.), all I see is a blank black screen. My monitor's backlight stays turned on, and my monitor continues receiving a video signal, there's just nothing displayed. If I run the tty terminals with Nouveau active, everything is displayed properly.

    Any ideas on what the issue is? My graphics card is an nvidia gtx460 if that's relevant.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    huh, that's weird. Are you logged into your desktop when you did this or were you using command line only?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Feb 2013
    Posts
    6
    This happens when starting Linux normally and getting to the log-in screen. I'd like to try running Mint in command-line only, but I haven't been able to figure it out. I read that it's initiated through recovery mode, but I couldn't find any options in there for a no-gui boot.

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Well, first of all....let's see what's under the hood. Please post the output of:
    Code:
    lspci -knn
    Code:
    lsmod
    Did you install the video card? Did it have an integrated video before? Tell us what you can about the machine, you know, system soecs and whatnot.

    EDIT: here is a howto that should help.
    http://forums.linuxmint.com/viewtopic.php?f=59&t=117643
    Last edited by MikeTbob; 02-27-2013 at 01:56 AM. Reason: See EDIT:
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #5
    Just Joined!
    Join Date
    Feb 2013
    Posts
    6
    Thanks a lot for the help. I tried running Mint through recovery mode again and realized that the default directory was root. I didn't know there was a cd .. command to up the directory. Long story short I installed the drivers through the root shell and everything seems to be working fine(for now). Thanks again.

  7. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Glad you got it working satisfactorily. Feel free to mark this thread as solved from the "thread tools" link at the top of this thread

    Sent from my SPH-D710VMUB using Tapatalk 2
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #7
    Just Joined!
    Join Date
    Feb 2013
    Posts
    6
    Small update: the tty issue remained after the installation of the nvidia drivers. As a quick test I switched to tty1 and connected my monitor to an onboard video port instead of my graphics card, and the tty prompt started working. Basically tty was being output through onboard video, while xorg was going through my graphics card. The solution is to just fully disable your onboard graphics, which for my board (asrock z68 extreme 3 gen 3 lga 1155) was to set both "render standby" and "IGD multi monitor" to disabled in the northbridge config page of the bios.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •