Find the answer to your Linux question:
Results 1 to 10 of 10
I’m pretty inexperienced with Linux & wanted to gain some expertise, so decided to install Mint 32-bit on an older Compaq Presario SR1403WM. Brief specs; AMD Sempron 3000+ at 1800 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7

    Trouble installing Mint on an older Compaq Presario SR1403WM


    I’m pretty inexperienced with Linux & wanted to gain some expertise, so decided to install Mint 32-bit on an older Compaq Presario SR1403WM. Brief specs; AMD Sempron 3000+ at 1800 MHz, 768 MB RAM.

    This is a freebie computer I’ve had around for a while, but have never installed on OS on before. The hard drive appeared to have failed & it only had 256 MB of RAM. I added a 512 MB stick & a different IDE hard drive. It boots from the Mint 14.1 DVD & the setup starts. It gets to a beige screen, has the mouse cursor & goes to an “hourglass” a few times as the screen flashes, as if the video driver is being installed, then just stops. Moving the mouse doesn’t move the cursor, it appears “frozen”.

    I booted to a Parted Magic Linux Live CD & the hard drive test failed, also when I tried to partition the drive EXT4, it failed with a non-specific error. Thinking the hard drive I installed must be bad, I installed another hard drive, that had been working in another PC. The Mint setup again failed in exactly the same way. Another piece of information; after the failed installation, the PC’s BIOS loses the drive (both drives tested). When you go into setup, it shows no hard drive, just the optical drive. I then run a boot CD, kill the partition & after a reboot it shows up again in the BIOS.

    To test the drive & system, I’m installing Windows XP on it, since I have more experience with Windows. As part of the install, I’m partitioning & fully formatting the drive (in progress now at 80%) as a test of the drive & system. If Windows installs without issue, I’ll at least know the system is functional. While Windows is on it, I’ll update the BIOS with the file from HP.

    This system has SATA connectors on the motherboard, so if I continue to have trouble with the IDE drives, I may install a SATA drive & see if that works.

    Can anyone comment if there have been any inherent issues with Linux on this particular model Compaq?

    Thanks for any & all help,

    ~Dave

    NOTE: If I manage to get Mint installed & running, I plan on buying a couple of 1 GB sticks of PC3200 (DDR400) to max the system out at 2 GB of memory. I may also install a graphics card & discontinue use of the integrated video.

  2. #2
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7
    Well, it looks like the hard drive & system itself are fine. I have Windows XP installed. I was able to get it on the Internet, install updates, etc. Not a single hardware related issue. I think I'll try the latest Ubuntu Desktop distro, in case it's something weird with Mint, though I don't know what that could be.

  3. #3
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,109
    It sounds like it might be a graphics problem. What graphics card do you have? If it does run, either MInt or Ubuntu will be slows with that RAM. Recommended is 1GB, see the site below:

    Linux Mint - Wikipedia, the free encyclopedia

  4. #4
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7
    Quote Originally Posted by yancek View Post
    It sounds like it might be a graphics problem. What graphics card do you have? If it does run, either MInt or Ubuntu will be slows with that RAM. Recommended is 1GB, see the site below:

    Linux Mint - Wikipedia, the free encyclopedia
    This old Compaq has integrated graphics, I'll have to use a diagnostic to see which particular chipset. Based on the results I'm getting and the point at which the install is failing, I think you're right about the graphics chip being the issue.

    I have several older AGP video cards available and there's an AGP slot in this box, so that may be the route to go. I'll have to research which cards have Linux drivers available.

    As to RAM, I only had a 512mb stick on hand for this machine, but if I get Linux up and running, I'll buy a couple of 1 GB sticks, for 2 GB total, which is max for this PC.

    Thank you for your input.

  5. #5
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7
    I tried booting from an Ubuntu 12.10 DVD and it did a similar thing; it actually gives me the Ubuntu drumbeat sound but the desktop doesn’t load and it just flashes, then the drumbeat sound triggers again and it does this repeatedly. With Ubuntu, I do get cursor movement when I move the mouse.

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,109
    Ubuntu requires a lot of resources as does Mint. You might try Lubuntu or Peppermint or if you are willing to go away from the Ubuntus, AntiX, precise puppy, slacko, slax are some other possibilities.

  7. #7
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7
    It seems the graphics chip was the problem, as yancek suggested. I installed an ATI Radeon X800 Pro 256mb graphics card I had available, which disabled the integrated graphics. I kicked off the installation again and it booted to Mint, including where you can select the installation configuration. I selected the option to install to the 120 GB hard drive with a single partition, using the entire drive.

    The first attempt failed, with an error about not being able to create a swap file on the SCSI drive. I'm giving it a second try this morning, but I'll watch the screen and note specific error messages, if any.

    If course with only 768mb of installed memory, it's VERY slow, but as I said, if I'm able to get Linux installed, I'll buy the 2 GB memory upgrade. 2 GB should give adequate performance, right? I won't be gaming or anything, just basic desktop apps. My goal is to learn how to configure and support Linux.
    Last edited by TangleWeb; 03-24-2013 at 01:48 PM.

  8. #8
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7
    OK, this is just TOO painful! I'm postponing this project till I have the 2 GM memory upgrade. Almost 2 hours just to boot to the Mint DVD is crazy. I think the performance should be acceptable once I boost it to 2 GB though.

    In the meantime, I'm going to install another hard drive in my primary desktop, an older Dell Optiplex 740 with an Athlon 64 X2 4800+ dual-core processor and 4 GB of RAM and install Mint on that. This way I’ll be using Linux as my primary desktop, but will still have my Windows 8 laptop for Windows stuff.

  9. #9
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7
    I just wanted to post that I attempted to install Mint 64-bit on the Dell Optiplex 740 (Athlon 64 X2 4800+ dual-core processor and 4 GB of RAM) and it wouldn't boot to the Mint Live environment, I think because it didn't like the integrated graphics. Interestingly, the 32-bit booted fine and I installed that.

    Then I installed a PCIe card I had available (ATI Radeon X1300 256mb), which disabled the on-board graphics, I was able to boot to the 64-bit version of Mint 14.1. I installed it alongside the 32-bit version, so I can boot into either. So, at least I have Mint up and running. It's pretty snappy on this old Dell.

    I have two 1 GB sticks of SDRam on the way for the Compaq this thread is about, so I will try installing Mint 32-bit on it, once the memory is upgraded.

  10. #10
    Just Joined!
    Join Date
    Aug 2013
    Posts
    1
    I came across your post as I was searching for RAM for my SR1403WM PC. I trust by now you have successfully installed Ubuntu on yours. FYI I have not had problems with Mint14 or 15 on mine, but I do have 1GB of RAM installed. Ubuntu was a bit slow and I did have problems due to using the resident graphics rather than an add-on graphics card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •