Find the answer to your Linux question:
Results 1 to 2 of 2
Well I did myself in this time. LOL!! I'm pretty savy with Linux but I've got a problem that I just can't seem to get around. I'm using Mint 13 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User TaZMAniac's Avatar
    Join Date
    Jan 2009
    Posts
    269

    PPA and Dependencies Help


    Well I did myself in this time. LOL!!
    I'm pretty savy with Linux but I've got a problem that I just can't seem to get around.

    I'm using Mint 13 with Mate.
    A dlna client with transcoding I was using complained that ffmpeg was degraded.
    I did some Google searching and saw that Ubuntu was now using Libav which the dlna client was not liking.

    So I found this site;
    Code:
    https://launchpad.net/~jon-severinsson/+archive/ffmpeg
    I installed the ppa and updated my repos.
    Updated the packages from his ppa and installed them.

    Now the problem. After I did this I noticed it was mentioned that the ffmpeg was an older version as Ubuntu did not have the newer version in the repo's that was not depreciated.
    DLNA client I use did not like it and I'm not keen on older versions with security holes in them.

    So I removed the ppa and then tried to force in the versions of packages from the official repo's.
    No good. It wants to remove pretty much all of my audio codecs and libraries along with numerous software titles.

    This is something I do not want happening as reinstalling some of those packages may not happen as they are part of the original install.
    It's happened to me before many years ago and the outcome was not good.

    I've tried ppa-purge but it still wants to uninstall software.
    Disabled all repos except for the official ones. No dice.
    Here is the list of libraries I need to change back to the officila versions;

    libavcodec53
    libavformat53
    libavutil51
    libpostproc-extra-52
    libpostproc52
    libswcale2

    I also tried removing them but I get the same warning about software and other libraries being removed.

    So the question is;
    How can I restore those libraries to the official repo ones without having it remove all my libraries and software?

    Thanks!

  2. #2
    Linux User TaZMAniac's Avatar
    Join Date
    Jan 2009
    Posts
    269
    Disregard the above post.
    On top of all this I now have a hard drive going bad.
    Lot's of I/O errors.
    Will swap out with newer hard drive and reload Mint.

    The biggest hassle will be setting up and syncing the 10 TB Raid 6 array that is running on that pc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •