Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I downloaded Mint Linux 14 and created a boot disk. I suscessfully boot off boot dvd. When running from my boot disc I tried to install a dual boot, whick ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2013
    Posts
    8

    Error: no such device


    I downloaded Mint Linux 14 and created a boot disk. I suscessfully boot off boot dvd. When running from my boot disc I tried to install a dual boot, whick seemed to run fine. When I then tried to boot with it I get the message:

    error: no such device ....
    <grub rescue>

    I have an Alienware running Windows Vista. I tried to boot from my Windows System Recovery disk, but get the same message.

    Any help would be appreciated

    Since I can only boot from the Mint DVD, I've been playing around with Linux to learn what I coould.

    My computer has a RAID 1 dual drives. Originally, they were 100 GB. A couple of years ago, one of them quit working, so I replaced both of them with 250GB drives. Since I replaced them 1 at a time to preserve all my data. I could only use 100GB on the drives.

    After trying some things in LINUX, it looks like it is installed in 150GB that Windows doesn't know about. The address that appears in the "Error: no such device" is the address where where Linus is installed, not where Windows is.
    Last edited by PaulPennock; 04-04-2013 at 10:51 PM. Reason: New information

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    After attempting the Mint install, were you able to successfully boot into Mint on the drive (without the DVD)?
    Were you able to boot windows vista?
    Something obviously went wrong with the bootloader installation. I would suggest you go the site below while booted with the Mint DVD, read the instructions, download and run the bootinfoscript. It will output a file named results.txt. If you post that here someone should be able to point you in the right direction as the info you posted isn't enough for anyone to do more than guess and the results.txt file contains a lot of pertinent info:

    Boot Info Script | Free System Administration software downloads at SourceForge.net

  3. #3
    Just Joined!
    Join Date
    Apr 2013
    Posts
    8
    After the Mint, I couldn't boot windows vista. I also can't boot Mint without the DVD.
    I downloaded the bootinfoscript, and tried to run it. I get a message that there is no such command.

    I ran the following from a terminal getting the associated messages:

    mint@mint ~ $ sudo ~/Downloads/bootinfoscript
    sudo: /home/mint/Downloads/bootinfoscript: command not found
    mint@mint ~ $ cd ~downloads
    bash: cd: ~downloads: No such file or directory
    mint@mint ~ $ cd ~/downloads
    bash: cd: /home/mint/downloads: No such file or directory
    mint@mint ~ $ cd /home
    mint@mint /home $ ls
    mint
    mint@mint /home $ cd mint
    mint@mint ~ $ ls
    Desktop Documents Downloads Music Pictures Public Templates Videos
    mint@mint ~ $ cd downloads
    bash: cd: downloads: No such file or directory

    I obviosly don't know enough about Linux.

  4. #4
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,561
    It may be that the script is not executable so running these commands may fix it

    Code:
    cd Downloads
    chmod +x bootinfoscript
    and then to run it

    Code:
    ./bootinfoscript
    if you get permission denied or similar then run the command again prefixing it with sudo.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  5. #5
    Just Joined!
    Join Date
    Apr 2013
    Posts
    8

    bootinfoscript results

    The attached file has the results from bootinfoscript.
    Attached Files Attached Files

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The reason you had problems accessing the bootinfoscript is you didn't take into consideration case sensitivity. Downloads is the name of the directory, not downloads. Also, to get to that directory you would do: cd /home/mint/Downloads, after that sudo ./bootinfoscript or bash bootinfoscript.sh or as suggested above, prefix with sudo.

    Anyhow, the problems are obvious from the end of the bootinfoscript. It has to do with RAID. I've never used RAID so I have no idea what you would need to do.

  7. #7
    Just Joined!
    Join Date
    Apr 2013
    Posts
    8
    Thanks for the feed back.

    Any suggests of where I could get help on the RAID?

  8. #8
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Any suggests of where I could get help on the RAID?
    Google? Since you are using Mint, you could try the Mint forums or Ubuntu since Mint is derived from Ubuntu. It might matter if you set up the RAID from windows and whether it is hardware or software RAID. Don't know enough to suggest anything else if you post at the other forums.

  9. #9
    Just Joined!
    Join Date
    Apr 2013
    Posts
    8
    Thanks!

    I was considering posting to the Mint site and I will do it. I need to research RAID as I don't know much about it at a tech level.

  10. #10
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,756
    Depending on your RAID setup, this thread may be helpful.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •