Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hello I add a ppa repository to my software manager and now evertime I go to update it says it can't find the repository I added it from the wine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Sep 2012
    Posts
    148

    Wine ppa problem


    Hello I add a ppa repository to my software manager and now evertime I go to update it says it can't find the repository I added it from the wine site WineHQ - Installing the latest Wine on Ubuntu
    I updated wine so I could play wow

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hi,

    can you show your apt sources? maybe a typo got in there:

    Code:
    cat /etc/apt/sources.list|grep -v ^#
    Last edited by atreyu; 05-07-2013 at 03:18 AM. Reason: added full path to sources.list

  3. #3
    Linux Newbie
    Join Date
    Sep 2012
    Posts
    148
    Ok here is what came up

    Code:
    deb http://packages.linuxmint.com/ nadia main upstream import
    deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
    deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
    deb http://archive.canonical.com/ubuntu/ quantal partner
    deb http://packages.medibuntu.org/ quantal free non-free
    thanks for the reply

  4. #4
    Linux Newbie
    Join Date
    Sep 2012
    Posts
    148
    Well I figured that I would just remove that repository, and fix it. But I want wine 5.1 because thats what I used when I installed wow and it played fine. I click on the link that says click here to install wine 1.5 and it says package wine 1.5 is a virtual package what does that mean? That I can't get wine 1.5 yet maybe?

  5. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    i added this line to my source.list and was able to then install wine:

    Code:
    deb http://archive.ubuntu.com/ubuntu quantal main
    this is what i ran first, to see if i could then see it:
    Code:
    $ sudo apt-cache search wine1.5
    wine1.5-i386 - Microsoft Windows Compatibility Layer (32-bit support)
    wine1.5 - Microsoft Windows Compatibility Layer (Binary Emulator and Library)
    wine1.5-dev - Microsoft Windows Compatibility Layer (Development files)
    wine1.5-dbg - Microsoft Windows Compatibility Layer (debugging symbols)
    and to install it:
    Code:
    $ sudo apt-get install wine1.5
    verify the installed version:
    Code:
    $ wine --version
    wine-1.5.29
    if you get apt errors, instead, paste them here into the thread so we can get a look.

    Edit: I take it back. You have that entry already, and I could install wine1.5 w/out adding the PPA. investigating...
    Last edited by atreyu; 05-08-2013 at 12:36 AM. Reason: see Edit

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    okay, found out why i could install it.

    first, since i could already see wine1.5 in an apt-cache search, i did this to determine the repo name:

    Code:
    $ apt-cache policy wine1.5
    wine1.5:
      Installed: (none)
      Candidate: 1.5.29-0ubuntu1
      Version table:
         1.5.29-0ubuntu1 0
            500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ quantal/main i386 Packages
    so there you see the ppa repo URL. then i did this to look for config files with that string in it:
    Code:
    $ grep -rl ppa /etc/apt/
    /etc/apt/sources.list.d/ubuntu-wine-ppa-quantal.list
    so it turns out i have a ppa repo defined, and I had forgotten about it. here is the full contents of the file:

    Code:
    deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu quantal main
    deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu quantal main
    try putting a file in that location with the above contents, then see if you can install it.

  7. #7
    Linux Newbie
    Join Date
    Sep 2012
    Posts
    148
    Ok I tried creating a file in /etc/apt/sources.list.d/ubuntu-wine-ppa-quantal.list using nano but everytime I try to install wine using:
    Code:
    sudo apt-get install wine 1.5

  8. #8
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    there is no space inb/t "wine" and "1.5", put it all together.

  9. #9
    Linux Newbie
    Join Date
    Sep 2012
    Posts
    148
    Hey that really helped thanks if I might ask how did you figure out the command line part of my problems where do you learn about the command line?

  10. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by awesomepilot View Post
    if I might ask how did you figure out the command line part of my problems where do you learn about the command line?
    when i was first learning Linux, i wanted to understand everything that happened in the background when i ran a graphical command. i found that pretty much all graphical commands have a simple command line counterpart. for example, system-config-user vs useradd. basically, it usually boils down to modifying some config file correctly, and knowing what commands to run to test it or enable it. to that end, the man pages are indispensable.

    for example, to add a user, i'd do:
    Code:
    man useradd
    in a terminal to read up on all the switches i could use when creating a new user. also, i would learn about the config files used by useradd, where i could put default values for new users for my system.

    and in the case of useradd, you could go even more rudimentary, and just edit /etc/passwd and /etc/shadow with a text editor to add a new user! but i don't recommend that, i'm just displaying one way of thinking about a problem.

    so basically, for any graphical tool that you use, see if it has a man page, or read the documentation to see what it is doing behind the scenes. there should be copious documentation for your Linux distro, and you really should have a copy of that on hand to rifle through. getting a Linux command line reference book is also a great idea.

    then of course, the big thing is trial and error. i spent a lot of time breaking stuff in the pursuit of learning how things worked. the package manager is a good place to start with this.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •