Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I have been trying for too long to switch from the Nouveau driver to nvidia driver 173 (.14.37) on Linux Mint Mate without success. I have tried a manual install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Asquared's Avatar
    Join Date
    Jul 2008
    Posts
    11

    Anybody ever heard of or see a successful installatio of nVidia drive


    I have been trying for too long to switch from the Nouveau driver to nvidia driver 173 (.14.37) on Linux Mint Mate without success. I have tried a manual install of the driver .run package downloaded from the nVidia web-site, or the 'Driver Manager' app., or using the Package Manager to install from the repository.

    In eveyr case the driver seems to get installed, but the X server will not start because it tells me (I think) that the xorg configuration file is invalid.

    Since there appears to be no way of recovering from this situation, I have to re-install Mint - I'm not on my 16th install in the last 10 days.

    Is there any evidence that this driver 173 has ever been successfully installed, anyway, in Mint Mate 15, replacing the Nouveau driver? If so, what has to be done - in detail?

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    This thread seems to contain the answer: How to get Nvidia's proprietary driver to work - Linux Mint Community

    Though, instead of updating GRUB, I recommend just blacklisting the module the old fashioned way Howto: Prevent a Linux kernel module from auto loading

  3. #3
    Just Joined! Asquared's Avatar
    Join Date
    Jul 2008
    Posts
    11
    Quote Originally Posted by mizzle View Post
    This thread seems to contain the answer: URL redacted to meet the needs of some anally-retentive bureaucrat

    Though, instead of updating GRUB, I recommend just blacklisting the module the old fashioned way (Again URL redacted to meet the needs of the same anally-retentive bureaucrat)

    Err, no, doesn't work - not even close. I tried this about a week ago. Waste of time.

    This is starting to convince me that nobody has ever actually installed the 173 driver on a supported GeForce card under Mint 15. There are lots of people who give advice on various ways they THINK it (might) work, but I never saw a claim from anybody who has actually done it. I too can think of lots of ways that it might work; for about 100% of the time I am mistaken. So there's clearly a hole in the design of the driver and installation process when combined. Sadly, I don't think there' any chance of anybody ever responding to this defect.

    Blacklisting the Nouveau driver confuses me too: after a clean install of Mint (yes, another one) there is no Nouveau module loaded into the Kernel according to lsmod output, so I can't see that blacklisting it is going to make any difference. But what do I know?

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,756
    While I don't have an old Quadro card lying around, I just installed this driver into a Mint 15 Mate OS without issue. *If* you need to do everything via a GUI, this install will likely be beyond your comfort zone/ability.

    1) Boot the OS
    2) Right-click the desktop and open a terminal
    3) Type in:
    Code:
    sudo service mdm stop
    - Your desktop session will end and you need to log into the non-GUI session.
    4) Type in:
    Code:
    sudo apt-get update && sudo apt-get install nvidia-173
    - The Nvidia 173 driver will be downloaded and installed by the package manager (APT.)
    5) Type in:
    Code:
    sudo reboot
    - The system will reboot and should now be using the Nvidia 173 driver.


    * The apt install automatically blacklists the nouveau driver, as evidenced (now) by the existence of: /etc/modprobe.d/nvidia-graphics-drivers.conf
    * The nouveau driver is definitely a module - modinfo nouveau
    * So is the nvidia driver - modinfo nvidia_173
    * With newer versions of X.org, there is no xorg.conf file needed. If you install the driver and have display issues, then you likely need further tuning (possibly because your monitor does not support some auto-sensing/tuning.) To create an xorg.conf (if needed), run the command 'sudo nvidia-xconfig' and then reboot.
    * If steps above are not detailed enough, I cannot help further.

  5. #5
    Just Joined! Asquared's Avatar
    Join Date
    Jul 2008
    Posts
    11
    Many thanks: the steps are clear enough and, significantly contain the word "should", as in "- The system will reboot and should now be using the Nvidia 173 driver".

    Sadly, Mint, like most other software (system or otherwise) is not well versed in the social niceties of duty and obligation: the process you have described is, in principle, one of the many approaches I have tried to installing this driver - it is certainly the approach I have used most frequently. The system gets to the 'now reboot' step ok, but obstinately fails to come up with anything usable other than a CLI. X server throws a tantrum and tells me that my X system is not configured correctly and proceeds to tell me some of the things it finds wrong (none of which are a result of any decision I made or that I can influence in this install process). Running nvidia-xconfig makes no difference to the state of X Server'ss sense of dissatisfaction - including renaming the xorg.conf file before hand.

    True: modprobe shows both modules you listed (but why doesn't 'nouveau' show in the output from lsmod?). I note that the nvidia-graphics-drivers.conf file also blacklists nvidia-173-updates - I wonder why?

    But, the bottom line is that this process does not end up with a usable system: it requires a re-install of the OS again, i.e. a reversion to the noveau driver.

    I should add that I have tried this process using 3 different monitors: a simple Dell E173FPc LCD, running (default) at 1280 x 1024 60 Hz. A Mitsubishi Diamond Pro 920 (using the Sony tube); this 19" CRT is capable of 1600 x 1200, up to 85 Hz. An Iiyama Vision Master Pro 454, 19" capable of 1920 X 1440 at 85 Hz.

  6. #6
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,569
    I'm only running M15 on a VM so haven't installed the nvidia driver on it but since version 5 it has always worked so here are some thoughts to throw in to the mix.

    Is 173 the correct driver, have you tried installing nvidia-current instead?
    What are some of the things it finds wrong? Have a look in ~/.xsession-errors and /var/log/Xorg.0.log
    Some of these are pretty old monitors.They may need a revival of the arcane art of mode lines and because I'm not entirely evil, a calculator

    [edit]Just found this in which may also help. You will probably need to adjust the modeline and modes in the file to suit your monitor.[/edit]
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  7. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Are you sure noveau is a module and not compiled into the kernel itself? That's one reason it wouldn't show up in the output of lsmod.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #8
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,756
    So I'll state the same thing again: *If* you need to do everything via a GUI, this install will likely be beyond your comfort zone/ability.

    You have done no troubleshooting. The nouveau driver is a module - it *should not* be listed by lsmod because...it's not loaded by the kernel. Modinfo "module_name" returns info as expected, along with the location of the module. Following the steps above, you have installed the nvidia_173 module. If you have further problems, it is because your system has further problems/requires tuning. *Re-installing the OS to try another set of steps is NOT the answer.* If an xorg.conf file exists and is giving you problems, delete it. If it's not there, create one. Review the X.org log - find the errors and search Google on those errors. If you want to remove the nvidia_173 driver, use the 'apt-get remove' command. In short, you either commit to learning, understanding, and troubleshooting, or you accept that you cannot get this driver installed - whether it is a software/hardware issue. You have a very old video card on a very recent Linux distro. You may find that an older distro will better support the older HW "out of the box."

  9. #9
    Just Joined! Asquared's Avatar
    Join Date
    Jul 2008
    Posts
    11
    I wrote a long reply to this (no, not this, the one I was replying to - by elija) post, taking most of the day on & off. But this forum told me 'the token has expired' and through it all away. Nice work; thanks.

  10. #10
    Just Joined! Asquared's Avatar
    Join Date
    Jul 2008
    Posts
    11
    Quote Originally Posted by MikeTbob View Post
    Are you sure noveau is a module and not compiled into the kernel itself? That's one reason it wouldn't show up in the output of lsmod.

    Good question - as a non-technical user where do I look for the answer?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •