Find the answer to your Linux question:
Results 1 to 4 of 4
Hello linux mint forum users. Yesterday i download a theme for my computer but one of the files from the theme had to be placed in /usr/share/cinnamon/theme to replace the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2013
    Posts
    2

    No permissions to modify file


    Hello linux mint forum users. Yesterday i download a theme for my computer but one of the files from the theme had to be placed in /usr/share/cinnamon/theme to replace the old menu.png file. Everytime i try to transfer the file or delete the original one i get an error saying that i have no permission. I also tried changing the permissions of the file using
    "~ $ chmod a=r /usr/share/cinnamon/theme/menu.png
    chmod: changing permissions of `/usr/share/cinnamon/theme/menu.png': Operation not permitted" but once again that did not work. Then i tried using vfat but once again it did not work "~ $ /usr/share/cinnamon/theme/menu.png vfat
    bash: /usr/share/cinnamon/theme/menu.png: Permission denied". Is there anyway i can change the permissions of the folder and change the file? Before you guys start answering the question i must admit that i just started linux a few days ago so i'm pretty much new to everything here. I'm not even sure i used the commands correctly.

    Thanks in advance

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    You need to give yourself root permissions to change files outside your /home directory. So prefix whichever command you use with sudo, you will be prompted for your primary users password, enter it and hit the enter key and you should be on your way. You might want read up on using the sudo command and getting root privileges on Mint.

  3. #3
    Just Joined!
    Join Date
    Mar 2013
    Posts
    8
    Yeah you need the rootly powers to do what your doing so you can either use sudo before what your typing in like yancek said or you can use the command sudo su to login as root and when you want to go back to your normal command line just use the command exit to leave the root account.

  4. #4
    Just Joined!
    Join Date
    Jun 2013
    Posts
    2
    Alright thanks guys the su command worked. Took me like 2 hours to figure it out because i kept getting errors but it turns out that i didnt capitalize a letter so it could not find the proper directory. Thanks for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •