Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I had Mint 15 installed on my computer with dual boot via windows 8 and then i successfully uninstalled mint by removing the linux partitions. I then reinstalled Mint ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7

    Mint 15 missing from bios with dual boot windows 8


    Hello,

    I had Mint 15 installed on my computer with dual boot via windows 8 and then i successfully uninstalled mint by removing the linux partitions. I then reinstalled Mint 15 in order to create a larger partition. Now my problem is that there is no way for me to boot into linux, my computer boots straight to windows 8 and when i go into the bios, linux does not show up in boot options. I checked the partitions and linux successfully installed in a new partition. I do not have an optical drive and installed mint using a usb flash drive. I can boot linux from the usb, but it just asks me to go through the whole installation process again.

    It would be greatly appreciated if someone could please help me fix this problem. I dont even need the dual boot option when I turn on my computer... I only need Linux to appear in BIOS.

    Thank you very much

    also, I am brand new to the linux world so if you could please offer step by step guidance, again, very much appreciated.

    Thanks!

    Jess
    Last edited by linuxjess; 09-12-2013 at 09:54 PM.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I can boot linux from the usb, but it just asks me to go through the whole installation process again.
    Well, that would be expected behavior if you are booting the flash drive you used to install Mint. You are just booting the flash drive again. If you have windows 8, you may have to disable Secure Boot and/or enable Legacy boot. The options to boot in BIOS will show drives, hard drives, usb external, CD or DVD not a specific partition or system. You obviously did not install the Mint Grub bootloader to the master boot record or windows 8 would not be booting. Check the BIOS for the Secure and Legacy boot options.

  3. #3
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Hello Yancek,

    Thank you for your response. I already have secure boot disabled and enabled legacy boot. I would actually prefer for linux to automatically start and then i can access windows whenever i want to in the BIOS (which i know how to do as long as linux it appears in BIOS). I just need linux to appear in BIOS. You mentioned "You obviously did not install the Mint Grub bootloader to the master boot record or windows 8 would not be booting." how do i go about installing that?

    Thanks again for your time

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The easiest way is during the installation where you have the option to install "Device for bootloader installation" and the default is usually /dev/sda which means the mbr of the first drive. Since it's too late for that, I would suggest you take a look at the site below which has a number of options suggested. Although it is an Ubuntu site, the steps are the same as Mint is an Ubuntu derivative. Try booting the flash drive and using the option at the site below "via the Live CD terminal".

    https://help.ubuntu.com/community/Gr...talling_GRUB_2

  5. #5
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Hello Yancek,

    Thank you for all your help. I finally found a solution howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/

  6. #6
    Just Joined!
    Join Date
    Aug 2013
    Posts
    7
    Quote Originally Posted by linuxjess View Post
    howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/
    It wouldnt let me post a link yet so the above is a legit URL that helped me in case anyone else encounters this problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •