Find the answer to your Linux question:
Results 1 to 3 of 3
hi, i have messed up my vlc installation. i used the instructions on this site Install VLC 2.1.0 on ubuntu 13.04/12.10*|*Ubuntu Geek to install vlc on mint thinking that both ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    36

    messed up vlc and now i cant reinstall it


    hi, i have messed up my vlc installation. i used the instructions on this site Install VLC 2.1.0 on ubuntu 13.04/12.10*|*Ubuntu Geek to install vlc on mint thinking that both ubuntu and mint are very similar so it should work. now when i try to reinstall vlc i get this error:
    Code:
    The following packages have unmet dependencies:
     vlc : Depends: vlc-nox (= 2.0.8-0ubuntu0.13.04.1) but 2.0.8+git20130930+r616-0~r51~ubuntu13.04.1 is to be installed
           Recommends: vlc-plugin-notify (= 2.0.8-0ubuntu0.13.04.1) but 2.0.8+git20130930+r616-0~r51~ubuntu13.04.1 is to be installed
           Recommends: vlc-plugin-pulse (= 2.0.8-0ubuntu0.13.04.1) but 2.0.8+git20130930+r616-0~r51~ubuntu13.04.1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    i have removed the ubuntu ppa and that is what i get. i want to completely get rid of the ubuntu ppa and reinstall the original vlc that comes with mint. the ubuntu one when installed wouldnt play dvd's. thanks for the help

  2. #2
    Just Joined!
    Join Date
    Aug 2013
    Posts
    36
    figured it out.
    Code:
    sudo aptitude -f

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,753
    Glad you found a fix, however knowing what's going on with regard to vlc not playing commercial DVDs, that is a matter of needing libdvdcss (and/or libdvdcss2) installed so it can decode commercial discs. Installing vlc won't do that automatically.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •