Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, It's been a long time since i needed any help with Linux but now I'm at the point of tearing my hair out. I'm using Mint 13 with Mate ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User TaZMAniac's Avatar
    Join Date
    Jan 2009
    Posts
    269

    mdadm Raid 6 Issues


    Hi,

    It's been a long time since i needed any help with Linux but now I'm at the point of tearing my hair out.

    I'm using Mint 13 with Mate desktop.
    I've been running a mdadm Raid 6 system for quite some time.
    It consists of 4 hard drives consisting of 2TB's each.

    Yesterday I went to access my Raid 6 at md0 using the icon found in the Computer folder.
    The icon was not present.
    When i opened Disk Utility and checked the Raid 6 entry it showed it was up and running.
    All drives show no errors and they are in the proper configuration.

    I decided to stop mdadm and do a repair/resync.
    That is when i noticed that when I stopped mdadm the icon I usually click on appeared in the Computer folder.

    Today the repair/resync finished but I am still unable to access it.

    I tried numerous commands to check the array and disks and nothing appears to be wrong.
    My Raid 6 uses the following drives;
    sde, sdf, sdg, sdi

    If I try to mount md0 from the terminal using mount /dev/md0 I get an error that md0 is not found in fstab.
    So I added an entry in fstab to mount it on boot.
    It did not mount and generated no error messages.

    I checked the kernel logs and they all have the same entries for the past week.
    In fact i have another hard drive that has Mint on it and also ran my Raid 6. I replaced it about 3 months ago with a new drive because it was failing.
    The kernel logs on that drive have the same entries for mdadm and md0 that my new drive has.

    Here is a copy of today's kernel logs;

    Code:
    ar 23 10:11:20 DaLinux kernel: [    5.551901] md: bind<sdf>
    Mar 23 10:11:20 DaLinux kernel: [    5.569025] md: bind<sde>
    Mar 23 10:11:20 DaLinux kernel: [    5.572212] md: bind<sdi>
    Mar 23 10:11:20 DaLinux kernel: [    5.601595] md: bind<sdg>
    Mar 23 10:11:20 DaLinux kernel: [    5.629825] bio: create slab <bio-1> at 1
    Mar 23 10:11:20 DaLinux kernel: [    5.629840] md/raid:md0: device sdg operational as raid disk 2
    Mar 23 10:11:20 DaLinux kernel: [    5.629842] md/raid:md0: device sdi operational as raid disk 3
    Mar 23 10:11:20 DaLinux kernel: [    5.629844] md/raid:md0: device sde operational as raid disk 0
    Mar 23 10:11:20 DaLinux kernel: [    5.629845] md/raid:md0: device sdf operational as raid disk 1
    Mar 23 10:11:20 DaLinux kernel: [    5.630175] md/raid:md0: allocated 4280kB
    Mar 23 10:11:20 DaLinux kernel: [    5.630222] md/raid:md0: raid level 6 active with 4 out of 4 devices, algorithm 2
    Mar 23 10:11:20 DaLinux kernel: [    5.630224] RAID conf printout:
    Mar 23 10:11:20 DaLinux kernel: [    5.630225]  --- level:6 rd:4 wd:4
    Mar 23 10:11:20 DaLinux kernel: [    5.630226]  disk 0, o:1, dev:sde
    Mar 23 10:11:20 DaLinux kernel: [    5.630227]  disk 1, o:1, dev:sdf
    Mar 23 10:11:20 DaLinux kernel: [    5.630228]  disk 2, o:1, dev:sdg
    Mar 23 10:11:20 DaLinux kernel: [    5.630229]  disk 3, o:1, dev:sdi
    Mar 23 10:11:20 DaLinux kernel: [    5.630250] md0: detected capacity change from 0 to 4000528203776


    Here is is the output of cat /proc/mdstat:

    Code:
    $ cat /proc/mdstat
    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10] 
    md0 : active raid6 sde[0] sdi[3] sdg[2] sdf[1]
          3906765824 blocks super 1.2 level 6, 512k chunk, algorithm 2 [4/4] [UUUU]
          
    unused devices: <none>
    I tried the following command and here is the output;

    Code:
    sudo mdadm --assemble --force /dev/md0 /dev/sd[efgi]
    mdadm: /dev/md0 has been started with 4 drives.
    I also ran this command and it shows that md0 is clean;

    Code:
    sudo mdadm --detail /dev/md0
    
    /dev/md0:
            Version : 1.2
      Creation Time : Mon Jan 21 21:21:18 2013
         Raid Level : raid6
         Array Size : 3906765824 (3725.78 GiB 4000.53 GB)
      Used Dev Size : 1953382912 (1862.89 GiB 2000.26 GB)
       Raid Devices : 4
      Total Devices : 4
        Persistence : Superblock is persistent
    
        Update Time : Sun Mar 23 16:10:38 2014
              State : clean 
     Active Devices : 4
    Working Devices : 4
     Failed Devices : 0
      Spare Devices : 0
    
             Layout : left-symmetric
         Chunk Size : 512K
    
               Name : DaNixBox:0
               UUID : 320fd47e:235e2eee:675ae146:6bb49a2e
             Events : 46
    
        Number   Major   Minor   RaidDevice State
           0       8       64        0      active sync   /dev/sde
           1       8       80        1      active sync   /dev/sdf
           2       8       96        2      active sync   /dev/sdg
           3       8      128        3      active sync   /dev/sdi

    Any help would be appreciated.
    Thanks!
    Last edited by TaZMAniac; 03-23-2014 at 09:31 PM. Reason: Added Info

  2. #2
    Linux User TaZMAniac's Avatar
    Join Date
    Jan 2009
    Posts
    269
    I'm going to mark this as solved.
    I ran sudo fsck /dev/md0
    Found some corruptions and inode errors on the array.
    It fixed what it could but says there are still corruption errors on the drives.

    I plan on backing up the array and then finding which drives have the problems.
    I almost have a hunch that the problem lies in the Sata bus.
    I say this because I had to replace a hard drive due to the same errors.
    The mobo is several years old and has been used hard.

    Peace out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •