Find the answer to your Linux question:
Results 1 to 7 of 7
I have managed to install Linux Mint17 on a computer in conjunction with WindowXP and can see the internet and a Windows7 computer on my home network. However the Windows7 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2014
    Location
    Leicestershire, UK
    Posts
    9

    Home network connection


    I have managed to install Linux Mint17 on a computer in conjunction with WindowXP and can see the internet and a Windows7 computer on my home network. However the Windows7 machine can't see any content when viewing the Linux computer under Network. Please help.

  2. #2
    Linux Enthusiast
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    675
    Did you install and configure SAMBA?

    Since I do not do windows, I can help more than that. Unix since 1976.
    Last edited by alf55; 07-26-2014 at 02:36 AM.

  3. #3
    Just Joined!
    Join Date
    Jul 2014
    Location
    Leicestershire, UK
    Posts
    9
    Yes, SAMBA is already installed but I don't know how to configure it.
    Personal File Sharing Preferences says it needs gnome-user-share. But that is already installed. That also needs WebDAV which I can't find.
    Should Linux have a SharedDocs folder like in Windows?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2014
    Location
    Leicestershire, UK
    Posts
    9
    There is a folder called Public in Home folder on Linux. I have allowed sharing on this folder but although the Windows computer can see the folder, access is not allowed.

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    11
    Hello Brian

    If you are still having problems with this I suggest that you login to the Linux Mint Forum where there are some very good tutorials.

  7. #6
    Just Joined!
    Join Date
    Jul 2014
    Posts
    18
    SAMBA FILE SHARE

    sudo apt-get install samba

    Put this at the bottom of the file:

    [share]
    comment = Share
    path = /srv/samba/share (whatever path to whatever shared folder)
    browsable = yes
    guest ok = yes
    read only = no
    create mask = 0755

    sudo service samba restart
    chmod a+rw /path/to/shared folder

    Should be done. Hope this helps

  8. #7
    Just Joined!
    Join Date
    Jul 2014
    Location
    Leicestershire, UK
    Posts
    9
    I was having trouble with the hard drive that Linux Mint17 was installed on. So I dispensed with that drive and installed Linux Mint17 dual boot in a partition on the WindowsXP drive. All I needed to do was enter the network name & now the Windows7 computer can see the Public folder on Linux and Linux can see the SharedDocs folder on Windows7.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •