Find the answer to your Linux question:
Results 1 to 10 of 10
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    No Sound - No Password

    I'm brand new to Linux, just having installed Mint Cinnamon Sylvia a few days ago. I was really hoping everything went smoothly as I have a lot to learn as all my previous computer experience is pushing buttons and selecting items from menus. The installation went fine. sound. This eliminates my possibility of getting help from YouTube. I searched online and found different answers for this issue and am a little hesitant to proceed.

    I'm not on that computer right now. I tried the driver manager and it offers two options for intel drivers. This is a Lenovo Thinkpad laptop. I saw some instructions for some console input, "sudo alsa force-reload," and I get asked for a password. I enter the only password I gave to install it, and the password fails.

    The layout for the system looks great and I'm anxious to jump in, but...

    Is there an easy way to update ALL the drivers?


  2. #2
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Yes and no. Normally all drivers are part of Linux kernel, so when kernel is upgraded all drivers are upgraded as well.
    However. There are corner cases when quirky hardware requires additional setup. For instance, I think I read somewhere Lenovo sound may need additional parameters passed to the existing driver. You may find a tutorial and more info on Thinkpad forums, they have a subforum dedicated to Linux.

    Thinkpad forum

  3. #3
    Linux Guru
    Join Date
    Dec 2013
    Quote Originally Posted by GTRRO View Post
    I saw some instructions for some console input, "sudo alsa force-reload," and I get asked for a password. I enter the only password I gave to install it, and the password fails.
    HOW does it fail?
    on a linux console, you don't get visual feedback when entering the password.
    a succesful command often doesn't output anything.

    it's best if you copy-paste the terminal output here.
    use code tags for code.

    Is there an easy way to update ALL the drivers?
    IF this is a driver issue, the point is to find & activate the appropriate driver for your hardware, not necessarily the newest.
    but let's not jump to conclusions.
    things to try:

    in a terminal, enter 'alsamixer' and UNmute all relevant channels by highlighting it, then typing 'M'.
    obviously, a _muted_ channel shows 'MM', so you want to change that.

    on your panel, try right-clicking the sound icon and getting into the mixer, and again make sure that all sound is UNmuted. different because this is a graphical app.

    IF that doesn't help, post output of
    lspci -k | grep -A5 Audio
    use code tags for code.

  4. $spacer_open
  5. #4
    I guess 'fail' was a bad choice of words. I copied some text (as I noted in original post) and I got the msg about being privy to other's privacy and a mention of the system administrator (which I suppose means I do not have access to my system from the root) and when asked for a password, the prompt did not move as I entered what I thought was my password.

    I do not have my Linux laptop here today but will bring it tomorrow and copy the text you provided. Thanks so much and I'll report back of the results.

  6. #5
    The sound was not set to mute.

    When I entered the code, this is what my computer reported:

    00:1=1f.3 Audio device: Intel Corp Sunrise Point-LP HD. Audio (rev 21)
    Subsystem: Lenovo Sunrise Point-LP HD Audio
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl
    00:1F.4 SMBus: Intel Corp Sunrise Point-LP SMBus (rev 21)
    Subsystem: Lenovo Sunrise Point-LP SMBus
    Kernel modules: i2c i801

    Is this indicating why I have no sound?

  7. #6
    Linux User
    Join Date
    Dec 2017
    The message you got happens only the first time, and doesn't mean anything.

    When you type your password nothing will change in the screen. Just type it and press Enter. If it doesn't work then that's not the password. And it is the one you use during installation.

    I believe Mint has the Pulseaudio applet active by default. You could see if it's muted there.

    Sent from my Moto G Play using Tapatalk

  8. #7
    Linux Guru
    Join Date
    Dec 2013
    go back to my previous reply.
    read it again. take your time, read it ALL.

    now answer the questions and post what was requested. all of it, not only 50%. use code tags for code. do not paraphrase, show us the actual messages (you can copy-paste the contents of your terminal, no screenshots please.

  9. #8
    I was not connected to the internet, which is why I could not paste code in the forum. But I am online now but am writing this on another computer so I can upload an image that might be important to my problem. I opened the Driver Manager and ran it and got a msg box with information I want to share. Since I don't know how to do a screenshot on Mint yet, I took a picture of the msg and am posting it here. I am not familiar with Linux enough to do this on my Linux machine.


    I will respond to your instructions from my Linux machine in another reply. Perhaps the information in the photo is key to my problem.

    I'm not sure the link to the image is working.

    It is a msg about Intel. This pops up after I run the Driver Manager.

    The box gives me two options.

    First it lists my processor: i5-6200U CPU@2.30GHz

    Then the choice:

    Processor microcode
    Intel-microcode (open source)

    1. Version 3.20180108.0+really20170707 ubuntu16.04.1

    2. Do not update the CPU microcode.
    Last edited by GTRRO; 03-14-2018 at 10:48 PM.

  10. #9
    Linux User
    Join Date
    Dec 2017
    Image is broken for me. Just type the error message here...

  11. #10
    I HAVE SOUND. I was checking the sound level settings, and they looked good. Then I ran a test to test the sound and there was none, but when I then tried to test a few sound effects, I suddenly have sound.

    I will watch videos on Linux and get more familiar with it. I also am reading a book that explains a lot of the code words. I have used Windows for years but only applications, entering very little CMD line. Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts