Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Can No longer access my SMB share?


    I'm running Linux Mint 19 Tara 64-bit, Kernal Linux 4.15.0-20 generic x86_64, Mate 1.20.1.

    All of a sudden I have lost the ability to connect to my SMB share on this machine. I was copying data over to it just fine and now I can't anymore. The client that I'm using is a Windows 10 and an Android. Before all this happened I had copied like 40GB of data already. I tried a simple restart but that Didn't work. What the hick would just make the SMB share not accessible anymore?

    This is what I did to create the share (that was working).
    Install Samba
    ○ sudo apt-get update
    sudo apt-get install samba
    Set a password for your user in Samba
    ○ sudo smbpasswd -a <user_name>
    Create a directory to be shared
    mkdir /home/<user_name>/<folder_name>
    Make a safe backup copy of the original smb.conf file to your home folder, in case you make an error
    sudo cp /etc/samba/smb.conf ~
    Edit the file "/etc/samba/smb.conf"
    sudo nano /etc/samba/smb.conf
    Once "smb.conf" has loaded, add this to the very end of the file:

    [<folder_name>] - make sure you use [] around the share name
    path = /home/<user_name>/<folder_name>
    valid users = <user_name>
    read only = no

    Restart the samba:
    sudo service smbd restart

  2. #2
    -->
    Quote Originally Posted by finsfree View Post
    I'm running Linux Mint 19 Tara 64-bit, Kernal Linux 4.15.0-20 generic x86_64, Mate 1.20.1.

    All of a sudden I have lost the ability to connect to my SMB share on this machine. I was copying data over to it just fine and now I can't anymore. The client that I'm using is a Windows 10 and an Android. Before all this happened I had copied like 40GB of data already. I tried a simple restart but that Didn't work. What the hick would just make the SMB share not accessible anymore?

    This is what I did to create the share (that was working).
    Install Samba
    ○ sudo apt-get update
    sudo apt-get install samba
    Set a password for your user in Samba
    ○ sudo smbpasswd -a <user_name>
    Create a directory to be shared
    mkdir /home/<user_name>/<folder_name>
    Make a safe backup copy of the original smb.conf file to your home folder, in case you make an error
    sudo cp /etc/samba/smb.conf ~
    Edit the file "/etc/samba/smb.conf"
    sudo nano /etc/samba/smb.conf
    Once "smb.conf" has loaded, add this to the very end of the file:

    [<folder_name>] - make sure you use [] around the share name
    path = /home/<user_name>/<folder_name>
    valid users = <user_name>
    read only = no

    Restart the samba:
    sudo service smbd restart
    In fact, I can't share with the GUI either using "Share Options".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •