Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2014

    Unhappy My new AMD Ryzen 5 computer build won't install Linux Mint 19.1.

    My new AMD Ryzen 5 computer build won't install Linux Mint 19.1.
    I downloaded ISO file, Checked Mdsum, put Iso on thumbdrive with UnetBootin.
    I updated Bios on MSI motherboard to the latest version 12, turned XMP profile and gaming profile on so that my ram is clocked at 2933mgh and cpu is at 3.9Ghz.
    Put drive in usb port and booted to it. Saw the Linux Mint menus and clicked on it but all I get is a black screen. Motherboard sees it as two usb drives. One as a UEFI and the other as Legacy Usb. I tried booting from both versions . Both give me the choice to boot Linux Mint but both give me black screen.

    AHCI mode choices are AHCI or RAID so it is set to AHCI (There is no “NOTIDE” mode)
    Windows 10 WHQL support is Disabled
    XHCI Handoff is Enabled
    Legacy USB Support is enabled along with UEFI
    I put Windows 10 on thumbdrive and that will boot up and try to install windows succesfully, but I cancel it.

    Here is my Hardware:
    Motherboard….MSI B450M Mortar with profiles and bios mentioned above
    CPU…………..AMD Ryzen 5 2400g 3.6 Ghz set to 3.85Ghz
    Memory………Corsair Vengeance LPX 16GB (2X DDr4 3200 clocked to 2933
    Storage……….Samsung Evo 250gb M.2 2280
    Power………...Corsair CXM 450Watt 80+ certified
    Case………….Silverstone GDO4 Usb3 HTPC

    This is my first AMD build all the rest are Intel. Thought Amd worked out the past problems with Linux so I thought I was safe.
    I looked around the bios to see if I was missing anything.
    Anyone have any Ideas?
    I will try installing another Linux Distro to see what happens but Linux Mint is the one I use for all my other machines.

  2. #2
    Quote Originally Posted by zyanni View Post
    Anyone have any Ideas?
    nomodeset? I don't how to get to that with Mint, but on *buntus at one stage it was F6.

    Regards, John Little

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts