Find the answer to your Linux question:
Results 1 to 4 of 4
I have a CD with my backup on it, actually I have 160 CD's with data on them. The directories and files are all listed, they have a file size ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Florida
    Posts
    6

    Can view CD cannot copy from it


    I have a CD with my backup on it, actually I have 160 CD's with data on them.
    The directories and files are all listed, they have a file size and everything looks great, until I try to copy a file from the cd, then I get an i/o error.

    The CD was created on a MDK9.2 Linux system, he data was cop-ied from a samba share on a mdk 9.2 server.

    I've tried reading the CD's in several drives, the original CDRW burner, a client station DVD/CD drive at the workplace, my DVD/RW, my CDRW and My laptop CD Drive.
    I tried reading the CD under MDK Linux 9.2 and 10 and Windows 98 and Windows XP.

    I have extracted the image using dd (dd if=/dev/cdrom of=damncd.hell)
    I can mount the image with loop, but I still can't copy files out of it.
    I was able to copy files out of one of the directories, but not the others. It really seems like a permission thing, but I've tried as root to no avail.

    I've even used: cat damnedcd.hell > pleasework.img
    chmod -Rf 0777 pleasework.img
    nothing... actually same as before.

    I can open the image file in a text editor, but the file formats are lotus123, so they are not recognizable to my untrained human eye.


    Please help me.......

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    Kinda sounds like the permissions werent preserved whan the disks were burned......
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Code:
    ls -al /wherever the cd is mounted
    And post the output.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I don't really get it. You say that you get an I/O error - how can you possibly get that to be a permission error?

    If the error you're getting really is I/O error (EIO, that is), check the end of the dmesg ("dmesg | tail -30") and see if the kernel has said something. The kernel can return EIO in case of filesystem corruption as well, not just when it can't read from the underlying device, but it usually clarifies what goes wrong in the dmesg.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •