Find the answer to your Linux question:
Results 1 to 8 of 8
I really couldn't care less but a few other recent posts have got me moving for a solution. Gentoo. On "# shutdown now" it does it's business til it gets ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305

    Distro not shutting down....


    I really couldn't care less but a few other recent posts have got me moving for a solution.

    Gentoo.

    On "# shutdown now" it does it's business til it gets to "Saving random seed" or summat like that. And that's as far as it gets. Just sits there, no activity, nothing.

    Reboot works fine.

    Any ideas/pointers?

    Ta.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Anything telling in your logs?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Quote Originally Posted by sarumont
    Anything telling in your logs?
    Which ones
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  4. #4
    Just Joined!
    Join Date
    Jul 2004
    Location
    por ahi
    Posts
    19

    Kernel

    I have a similar problem in the past, but my solution is a recompile the Linux kernel and set on the APM or ACPI option (see if your hardware it's compatible with APM or ACPI)

    Good luck dude.

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99
    I don't know if the command works for Gentoo, but to shut down from Slackware I type:

    Code:
    shutdown -h now
    Maybe you should try that. I can give you a much better answer because I haven't worked with this OS for very long. Before that I just turned it off at the boot loader or shutdown in Windows (in your case that would be Mandrake - am I right?)

  6. #6
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Will try tonight with the -h optin.

    Ta.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  7. #7
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    try also halt -p command..........
    Linux For Ever!

  8. #8
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99
    If my previous suggestion didn't work, you could also try:

    Code:
    telinit 0
    It has to be zero because that's the standard system shutdown number. I'm not sure whether this will work in Gentoo either but there's nothing to stop you trying.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •