modprobe: Can't open dependencies file /lib/modules/2.4.22-1.2174.nptl/modules.dep

In the messages log I have many instances of this and can not seen to find out how to correct it. running fedora.

In the /lib/modules here is what is there:
drwxr-xr-x 4 root root 4096 Jul 6 14:38 2.4.22-1.2197.nptl

looks like a newer version of what the machine is looking for.

Anyone have a fix for this?

Thanks
Ray