Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Wrong Entry in fsatb resulted in filesyatem being readonly

    Help me on this please...

    I have done the following entry mistakenly in fstab

    /dev/VolGroup00/LogVol00 / ext3 default,userquota 1 1

    So this has caused my whole filesyatem to be readonly. How can I recover from this statge.

    Thanks in advance

  2. #2
    Maybe this helps?

    /dev/VolGroup00/LogVol00 / ext3 default,userquota,rw 1 1

  3. #3
    But I can't change the fstab since all filesystem is readonly

  4. $spacer_open
  5. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    West Yorks
    You can boot from a live disc, mount your root (/) partition and edit the /etc/fstab.

  6. #5
    Linux Guru Lakshmipathi's Avatar
    Join Date
    Sep 2006
    3rd rock from sun - Often seen near moon


    i assume ur using Redhat/FC --Use installation CD , and choose rescue option
    and edit fstab file.
    I did this many times not a big issue to worry ..
    First they ignore you,Then they laugh at you,Then they fight with you,Then you win. - M.K.Gandhi
    FOSS India Award winning ext3fs Undelete tool Online Linux Terminal

  7. #6
    Thanks all... It is sorted but I am not sure how I did that. I didn't use boot disc...but did several umount and mount on various volumns...may be that sorted. Anyways thank you all for your help.

    regards and good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts