Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I'm trying to build an application from source, but apparently it has some dependency on Qt. I already have the headers installed, which is what puzzles me. Any ideas? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9

    dependency problem during build


    Hi,

    I'm trying to build an application from source, but apparently it has some dependency on Qt. I already have the headers installed, which is what puzzles me. Any ideas?
    Code:
    checking for Qt... configure: error: Qt (>= Qt 3.2) (library qt-mt) not found. Please check your installation!
    For more details about this problem, look at the end of config.log.
    Make sure that you have compiled Qt with thread support!
    As you can see, the dependencies are installed (Unless I'm missing something)
    Code:
    root@tkn-laptop:/home/tkn/incoming/protoeditor-1.1beta3# apt-cache search qt-mt
    libqt3-headers - Qt3 header files
    libqt3-mt - Qt GUI Library (Threaded runtime version), Version 3
    libqt3-mt-dev - Qt development files (Threaded)
    root@tkn-laptop:/home/tkn/incoming/protoeditor-1.1beta3# apt-get install libqt3-mt    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libqt3-mt is already the newest version.
    libqt3-mt set to manual installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@tkn-laptop:/home/tkn/incoming/protoeditor-1.1beta3#
    I'm using Ubuntu 7.10, but I have other KDE apps installed already, which runs just fine. I didn't install them from source though.

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    37
    What does it say at the end of config.log? Also try installing qt-devel if you haven't already done so.

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9
    config.log is 88K -- There's nothing special about the end of it. Here's the last couple of lines:
    Code:
    #define SIZEOF_LONG 4
    #define SIZEOF_SHORT 2
    #define SIZEOF_SIZE_T 4
    #define SIZEOF_UNSIGNED_LONG 4
    #define STDC_HEADERS 1
    #define ksize_t socklen_t
    #endif
    #ifdef __cplusplus
    extern "C" void std::exit (int) throw (); using std::exit;
    
    configure: exit 1
    apt-cache search gives no results on qt-devel. Do you mean one of these:

    Code:
    qt3-apps-dev - Qt3 Developer applications development files
    qt3-assistant - The Qt3 assistant application
    qt3-designer - Qt3 Designer
    qt3-dev-tools - Qt3 development tools
    qt3-doc - Qt3 API documentation
    qt3-dev-tools-compat - Conversion utilities for Qt3 development
    qt3-dev-tools-embedded - Tools to develop embedded Qt applications
    qt3-examples - Examples for Qt3
    qt3-linguist - The Qt3 Linguist
    qt3-qtconfig - The Qt3 Configuration Application

  4. #4
    Just Joined!
    Join Date
    Oct 2007
    Posts
    37
    I'd try this one:
    qt3-dev-tools

  5. #5
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9
    Quote Originally Posted by papetova View Post
    I'd try this one:
    qt3-dev-tools
    no dice. I installed it, but to no avail. I still get the same error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •