Find the answer to your Linux question:
Results 1 to 2 of 2
We have a GUI based socketserver.sh service, This service must be run in GUI based only in KDE, GNOME and X11 based only. May be this service coudn't work on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    India
    Posts
    1

    How Do I start GUI Based Service during Linux boot process


    We have a GUI based socketserver.sh service, This service must be run in GUI based only in KDE, GNOME and X11 based only. May be this service coudn't work on Linux Text terminal. Only work on X-terminal windows. Becauze We had tried using Text-mode these service coudn't work. After that We have tried on KDE X-terminal it will work fine. (Just Double click on that .sh file it will be execute.)

    But now we want to run these service duing linux boot process (like other linux service run in boot process eg. network, sendmail, smb, httpd etc.)

    We have tried following option to run our .sh file during linux boot process.

    1) In /etc/rc.d/rc.local
    /root/SocketServer/./Socketserver.sh # (My .sh file path)
    But it is not working.

    2) In /etc/rc.d/rc3.d
    ln -s /root/SocketServer/./Socketserver.sh S99socketserver
    we create a symbolik link with our .sh file and run after all service running.
    But it is not working.

    In this case our Linux Server is in Onsite Location. We don't have GUI based access like VNC, Xserver etc. Right now we are accessing our machine Using SSH (22).

    And even no human body is touch physically to enter username and password.


    Additon Information :
    1) We are accessing our Linux Server from our Onsite Location using SSH.
    2) Currnetly My Linux server RunLevel is 5 (Default Graphcally Interface)

    Required Solution :
    1) Is there any way we can start our service during linux bootup process.

    Hope you will get proper senario.

    Thanks in Advance.

    Pls. respond me as earlier as possible.

    Regards
    Uday Kulkarni
    System Admin.
    Uday.kulkarni@saterisystems.com

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    MN USA
    Posts
    70

    RE: How Do I start GUI Based Service during Linux boot proce

    Okay - I might be way off base here, cause I'm new myself!

    First, what do you mean it doesn't work in terminal?

    I know I have had to prefix some scripts with 'sh' to make them run, so sometimes a command like:
    Code:
    sh /root/SocketServer/./Socketserver.sh
    may work when script wont run in shell.

    Reason It'll work in X is the file associations setup in X telling it an .sh file is a shell script.

    Am I right or totally off? Let me know. Also let me know messages that output when you try to run.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •