I have a debian virtual machine in which the time keeps skewing. It has ntpd running against the same time server as all the other servers (which are all second accurate).

The Virtual Emulator is Microsoft's Virtual Server 2005 Enterprise Edition.

Is there a way I can stop this Debian system in the Virtual Machine from having this clock skew?

I have already tried something with the kernel parameter pit but this didn't seem to work.

Considering that the ntpd config is identical to all other servers and I know it works, I'm not sure why ntpd is so slow to correct this.

All other servers stay within 1 second accuracy, while this virtual one drifts out by 154 seconds (at the moment).

Perhaps I can make ntpd more shotgun or force the time to adjust according to what the time server says is the true time, or perhaps make it update more frequently?