Find the answer to your Linux question:
Results 1 to 2 of 2
I need to run a program that communicates with the serial ports. It runs fine as root, but as user it tells me I need to add group uucp to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907

    Groups users and the such


    I need to run a program that communicates with the serial ports. It runs fine as root, but as user it tells me I need to add group uucp to my group. So I go to MCC (Mandrake 10.0) and add uucp to jeremy. I get the same error, and when I use the groups command, it doesn't return uucp, just jeremy. In the /etc/group file, I have jeremy:uucp, but I'm not even listed in the /etc/gshadow file as a group at all! I also tried to edit those files using vigr with the same results.

    What am I doing wrong?

    Thanks,
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    You need to add the group if it's not already a valid group. Then you need to log in again after you add yourself to the group.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •