Find the answer to your Linux question:
Results 1 to 6 of 6
I have a Nokia Cell Phone Model # 6126 in which I purchased a Kingston 2gb Micro SD Card for. I want to be able to transfer photos and music ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    17

    Micro SD Card for Cell Phone Use with Linux???


    I have a Nokia Cell Phone Model # 6126 in which I purchased a Kingston 2gb Micro SD Card for.

    I want to be able to transfer photos and music to and from a Linux Computer. The Micro SD Card came with an SD size adapter. I also own a USB Card Reader (the ones that's about the size of a regular flash drive) so to do all this with.

    Do I have to format this Micro SD Card?

    If so, how do I do it and how do I get around Linux NOT even recognizing this card even though the card readers led light flashes then stays on steady without it being anywhere in Linux - even /Media.

    If I can get an explanation or even get pointed in the right direction - I'd really appreciate it as googling hasn't helped me in the least.

    I tried the "dmesg" command and below is the last 4 lines:

    [ 7227.168000] sd 6:0:0:0: [sde] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
    [ 7227.168000] sd 6:0:0:0: [sde] Sense Key : Medium Error [current]
    [ 7227.168000] sd 6:0:0:0: [sde] Add. Sense: Unrecovered read error
    [ 7227.168000] end_request: I/O error, dev sde, sector 903573496

    Thanks for your anticipated responses.

  2. #2
    Just Joined!
    Join Date
    Feb 2008
    Posts
    3
    Might be driver usb-storage not loaded.

    Load it with command.
    modprobe usb-storage

    and then mount the drive
    mount -t vfat /dev/sde /media/sde

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3

    usb-storage is mounted

    I have a similar issue. I just bought a microSD card and a reader (the kind without the USB shroud if it's important). I plug it into the computer, the light flashes and holds steady, and low and behold, no device is present. However, I get a slightly more extensive message about the device from dmesg:

    [ 6293.482200] usb-storage: device found at 18
    [ 6293.482668] usb-storage: waiting for device to settle before scanning
    [ 6298.483298] usb-storage: device scan complete
    [ 6299.044962] scsi 6:0:0:0: Direct-Access Generic 6000 PQ: 0 ANSI: 0 CCS
    [ 6299.057912] sd 6:0:0:0: [sdc] 3970048 512-byte hardware sectors (2033 MB)
    [ 6299.060895] sd 6:0:0:0: [sdc] Write Protect is off
    [ 6299.060911] sd 6:0:0:0: [sdc] Mode Sense: 4b 00 00 08
    [ 6299.060916] sd 6:0:0:0: [sdc] Assuming drive cache: write through
    [ 6299.072884] sd 6:0:0:0: [sdc] 3970048 512-byte hardware sectors (2033 MB)
    [ 6299.075896] sd 6:0:0:0: [sdc] Write Protect is off
    [ 6299.075915] sd 6:0:0:0: [sdc] Mode Sense: 4b 00 00 08
    [ 6299.075921] sd 6:0:0:0: [sdc] Assuming drive cache: write through
    [ 6299.075931] sdc:end_request: I/O error, dev sdc, sector 0
    [ 6299.207823] printk: 4 messages suppressed.
    [ 6299.207832] Buffer I/O error on device sdc, logical block 0

    The first 3 lines show that usb-storage is actually doing its job quite nicely, something is just conking out when it's looking for the drive cache. I'm guessing the problem may be that the assumption that the drive cache is "write through" is wrong, since that's when it all crashes. The device "sdc" doesn't appear anywhere on the computer (as I have 2 hard drives, no other USB drives, and the optical drives are both listed under "scd"). Anything wrong stick out of this log?

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    What is the output of fdisk -l command?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    Disk /dev/sda: 41.1 GB, 41110142976 bytes
    255 heads, 63 sectors/track, 4998 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000a5af2

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 31 248976 83 Linux
    /dev/sda2 32 4998 39897427+ 5 Extended
    /dev/sda5 32 4998 39897396 8e Linux LVM

    Disk /dev/sdb: 10.0 GB, 10005037056 bytes
    16 heads, 63 sectors/track, 19386 cylinders
    Units = cylinders of 1008 * 512 = 516096 bytes
    Disk identifier: 0x000d0c7b

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 19386 9770512+ 83 Linux


    So, it still doesn't recognize device "sdc".

  7. #6
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    Update - SD drivers should now be activated, yet it still doesn't work. I ran the following as root:

    modprobe tifm_core
    modprobe tifm_sd


    /sbin/lsmod had shown tifm_core and tifm_sd to be loaded right after I ran those commands, but since rebooting, now sd_mod is the only thing that looks active regarding SD cards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •