Find the answer to your Linux question:
Results 1 to 3 of 3
Hi. I am able to install xen. The command depmod (version)-xen also works correctly. After that when I try to give mkinitrd /boot/initrd-(version)-xen.img (version)-xen command, it gives an error - ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    6

    Problem in mkinitrd while installin xen


    Hi.
    I am able to install xen. The command depmod (version)-xen also works correctly. After that when I try to give mkinitrd /boot/initrd-(version)-xen.img (version)-xen command, it gives an error - No module pata_via found for kernel (version)-xen, aborting.
    I donno what the problem is...
    Earlier it was giving the same error in case of ehci-hcd module when i was using xen-3.0.2-2.src.tgz. But when i downloaded xen-3.0.3_0.src.tgz it gave the same error for module pata_via.
    I'm using FC8.
    Plz reply..

    Thanks in advance
    Prajakta

  2. #2
    Linux Newbie
    Join Date
    Mar 2008
    Location
    Hyderabad
    Posts
    109
    Do man mkinitrd
    You will find how to indicate that these things are in built in the kernel bzImage itself.
    2-3 more module errors might occur, just keep on giving --builtin option.
    It indicates that these modules are now builtin.
    By doing so i was successfully able recompile fresh kernel version.

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    6
    Hi.
    mkinitrd problem got resolved.
    Now, while booting xen i'm getting following errors:
    volume group "VolGroup001" not found
    mount: could not find file system '/dev/root'
    setuproot: moving /dev failed: no such file or directory
    setuproot: error mounting /proc: no such file or directory
    setuproot: error mounting /sys: no such file or directory
    mount failed: no such file or directory
    Plz help.

    Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •