Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
I formatted an external HD yesterday with my Macbook Pro to the HFS + Journaled file system, because I plan on using it as a media server for the Mac. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    58

    HFS + Journaled file system External HD not compatible w/Linux ?


    I formatted an external HD yesterday with my Macbook Pro to the HFS + Journaled file system, because I plan on using it as a media server for the Mac. I was about to copy my music directory from kubuntu to it, but it won't grant me access and I'm wondering if it's because of compatibility issues ? If this is so, I'm pretty sure that Ext 2 or 3 should work, so then my next question would be : What is the command to reformat my external drive to either of those formats ?

    Doug

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Ubuntu supports HFS+ pretty well. I am not sure if it allows write access too.
    Execute sudo fdisk -l command and note down partition names ( /dev/sdb1, sdb2 ) of External disk. Create a mount point ( folder ) for each HFS+ partition.

    Let say partition name is /dev/sdb1. Execute this
    Code:
    sudo fdisk -l
    sudo mkdir /dev/sdb1
    sudo mount -t hfsplus  /dev/sdb1  /media/sdb1
    ls /media/sdb1
    In case you have any confusion, post the output of sudo fdisk -l command here.

    * Its small L in fdisk -l command.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    58
    Ok, so the output was:

    Disk /dev/sdd: 163.9 GB, 163928604672 bytes
    255 heads, 63 sectors/track, 19929 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00000000

    Device Boot Start End Blocks Id System
    /dev/sdd1 1 19930 160086496+ af Unknown
    Using your example, I should :

    Code:
    sudo fdisk -l
    sudo mkdir /dev/sdd1
    sudo mount -t hfsplus  /dev/sdd1  /media/sdd1
    ls /media/sdd1

    Correct ? Or is it just sdd without the "1" ? Oh, and thanks so much DC, you're always patient and a great help.

    doug

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You are Welcome !
    It should be /dev/sdd1 only.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    58
    Cool beans. Going to try it right after I'm finished ripping/encoding a CD. You'll probably see a new thread/post from me in a few asking about LAME encoding settings. !

  6. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    58
    Something didn't go right in doing this just now. Here's the output:

    Code:
    Disk /dev/sda: 640.1 GB, 640135028736 bytes
    255 heads, 63 sectors/track, 77825 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0009b467
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1       77825   625129281    5  Extended
    /dev/sda5           76854       77825     7807590   82  Linux swap / Solaris
    /dev/sda6               1        2432    19534945+  83  Linux
    /dev/sda7            2433       76852   597778618+  83  Linux
    
    Partition table entries are not in disk order
    
    Disk /dev/sdb: 163.9 GB, 163928604672 bytes
    255 heads, 63 sectors/track, 19929 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00000000
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1               1       19930   160086496+  af  Unknown
    **********n@*****:~$ sudo mkdir /dev/sdb1
    mkdir: cannot create directory `/dev/sdb1': File exists
    m*********@*****:~$ sudo mount -t hfsplus /dev/sdb1
    Usage: mount -V                 : print version
           mount -h                 : print this help
           mount                    : list mounted filesystems
           mount -l                 : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
           mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
           mount device             : mount device at the known place
           mount directory          : mount known device here
           mount -t type dev dir    : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
           mount --bind olddir newdir
    or move a subtree:
           mount --move olddir newdir
    One can change the type of mount containing the directory dir:
           mount --make-shared dir
           mount --make-slave dir
           mount --make-private dir
           mount --make-unbindable dir
    One can change the type of all the mounts in a mount subtree
    containing the directory dir:
           mount --make-rshared dir
           mount --make-rslave dir
           mount --make-rprivate dir
           mount --make-runbindable dir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using  -L label  or by uuid, using  -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say  man 8 mount .
    **********@****:~$ ls /media/sdb1
    ls: cannot access /media/sdb1: No such file or directory
    *******@*****:~$
    Any clue ? When I try and copy/paste folders and files onto the drive, it says I can't create folders there.

    Doug

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It was my mistake ! Sorry !
    Execute this
    Code:
    sudo mkdir /media/sdb1
    sudo  mount   -t    hfsplus    /dev/sdb1   /media/sdb1
    ls /media/sdb1
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #8
    Just Joined!
    Join Date
    Jul 2006
    Posts
    58
    Hmm. I don't think this is a mounting issue, per-say. It says it's already mounted, but I just can't write to the disk.

    dev/sdb1 1 19930 160086496+ af Unknown
    **@**:~$ sudo mkdir /media/sdb1
    **n@**:~$ sudo mount -t hfsplus /dev/sdb1 /media/sdb1
    mount: /dev/sdb1 already mounted or /media/sdb1 busy
    mount: according to mtab, /dev/sdb1 is mounted on /media/Untitled
    **@**:~$ ls /media/sdb1
    **@**:~$
    Might I be better off just trying to reformat the drive ? I feel this would save time. Though I am curious to know why this wouldn't be working. I thought that when I was in OS X, that disk utility formatted (upon erasing) the drive using HFS+ Journaled, I mean.. it did take 2 hours or so !

    Doug

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Its already mounted at /media/Untitled folder. cd to that folder and try to create files in it.
    Code:
    cd /media/Untitled
    ls
    touch file1
    I am not sure if Linux supports HFS+ write access.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #10
    Just Joined!
    Join Date
    Jul 2006
    Posts
    58
    Ah Ha. You are indeed correct sir. Says can not touch. Read only file system. Ok, that in mind, OS X is able to read ext2 and ext3, correct ? How should I go about formatting this drive in that case ? Thanks for all of your help (again) btw.

    doug

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •