Find the answer to your Linux question:
Results 1 to 3 of 3
My /etc/fstab looks like this: /dev/VolGroup00/LogVol00 / ext3 defaults 1 1 LABEL=/boot /boot ext3 defaults 1 2 devpts /dev/pts devpts gid=5,mode=620 0 0 tmpfs /dev/shm tmpfs defaults 0 0 proc ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8

    How do you manually mount an LVM drive?


    My /etc/fstab looks like this:

    /dev/VolGroup00/LogVol00 / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/hdc2 swap swap defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
    /dev/hdb1 /mnt/backups auto defaults 0 2
    /dev/hdc1 /home auto defaults 0 2

    /boot is /dev/hda1 and / is /dev/hda2.

    When I installed FC I accidentally set / up as a LVM partition. Yesterday I had to do a rescue on my system with sysreccd - all I needed to do was mount the / partition and edit a file which had an error in it but I couldn't use the normal mount commands. I assume this is because / is under logical volume management.

    If I tried to mount /dev/hda2 I got "mount: wrong fstype, bad option, bad superblock on /dev/hda2, missing codepage or other error"

    I also tried mounting it using evmsn (ncurses version) but I couldn't work out how to mount it onto a directory anywhere.

    So how do you mount this type of partition manually when you've booted up with some sort of rescue CD?

    Regards,
    Phill

  2. #2
    Linux User
    Join Date
    Jun 2007
    Posts
    318
    I'm not familiar with sysreccd but I assume there's already a / (root) mounted from somewhere (the CD). So you'll have to temporarily mount on a different mountpoint, say /mnt. If it doesn't exist create it with mkdir. Then try this mount command:

    Code:
    mount -t ext3 /dev/VolGroup00/LogVol00 /mnt

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    Quote Originally Posted by vsemaska View Post
    Code:
    mount -t ext3 /dev/VolGroup00/LogVol00 /mnt
    I tried this but I get an error that the device doesn't exist. If I go to /dev there's no file or direcdtory called VolGroup00.

    Remember that I've booted up using a rescue disc here and I'm trying to mount a hard drive that isn' tmounted by the rescue disk (don't know if that changes your answer or not).

    Regards,
    Phill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •