Hello,

I am having issues with mounting an LVM2 partition under SUSE linux.
Note this is not my boot drive, but a secondary drive I would like to retrieve data from.

Disk /dev/sdc: 100.2 GB, 100256292864 bytes
255 heads, 63 sectors/track, 12188 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x074d074c

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 25 200781 83 Linux
/dev/sdc2 26 12188 97699297+ 8e Linux LVM

I want to mount a logical partition under /dev/sdc2.

I did the following.

root@APCM8:/jrwarner> pvs
File descriptor 3 left open
File descriptor 4 left open
File descriptor 5 left open
File descriptor 7 left open
PV VG Fmt Attr PSize PFree
/dev/sdc2 VolGroup00 lvm2 a- 93.16G 32.00M

root@APCM8:/jrwarner> lvchange -a y /dev/VolGroup00
File descriptor 3 left open
File descriptor 4 left open
File descriptor 5 left open
File descriptor 7 left open

root@APCM8:/jrwarner> lvscan
File descriptor 3 left open
File descriptor 4 left open
File descriptor 5 left open
File descriptor 7 left open
/dev/VolGroup00/LogVol00: read failed after 0 of 4096 at 0: Input/output error
ACTIVE '/dev/VolGroup00/LogVol00' [91.19 GB] inherit
ACTIVE '/dev/VolGroup00/LogVol01' [1.94 GB] inherit

root@APCM8:/jrwarner> mount -t ext3 /dev/VolGroup00/LogVol00 /home2
mount: wrong fs type, bad option, bad superblock on /dev/mapper/VolGroup00-LogVo l00,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

So either I am doing something wrong, or somehow something has been corrupted on my hard drive. I have some critical data on this drive that is unfortunenatly no backed up.

Any ideas how I can fix this problem or if I am doing anything wrong?