Find the answer to your Linux question:
Results 1 to 4 of 4
Quick question on mounting a partition under SUSE. I have a old Suse drive which I would like to copy all the data from. The drive information is shown below. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    2

    Mounting Linux Extended Partition


    Quick question on mounting a partition under SUSE.
    I have a old Suse drive which I would like to copy all the data from. The drive information is shown below.

    root@APCM8:/jrwarner> fdisk -l
    Warning: invalid flag 0x0000 of partition table 5 will be corrected by w(rite)

    Disk /dev/sda: 80.0 GB, 80026361856 bytes
    16 heads, 63 sectors/track, 155061 cylinders
    Units = cylinders of 1008 * 512 = 516096 bytes
    Disk identifier: 0x11209cdd

    Device Boot Start End Blocks Id System
    /dev/sda1 1 2081 1048792+ 82 Linux swap / Solaris
    /dev/sda2 * 2082 155061 77101920 85 Linux extended

    Disk /dev/sdb: 400.0 GB, 400088457216 bytes
    255 heads, 63 sectors/track, 48641 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x39b039af

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 262 2104483+ 82 Linux swap / Solaris
    /dev/sdb2 * 263 2873 20972857+ 83 Linux
    /dev/sdb3 2874 48641 367631460 83 Linux

    Disk /dev/sdc: 100.2 GB, 100256292864 bytes
    255 heads, 63 sectors/track, 12188 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x074d074c

    Device Boot Start End Blocks Id System
    /dev/sdc1 * 1 25 200781 83 Linux
    /dev/sdc2 26 12188 97699297+ 8e Linux LVM
    Disk /dev/dm-1: 2080 MB, 2080374784 bytes
    255 heads, 63 sectors/track, 252 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x30307800

    Disk /dev/dm-1 doesn't contain a valid partition table

    I believe the partition I want to mount is /dev/sda2.
    When I go to mount this I get the following error:

    root@APCM8:/jrwarner> mount /dev/sda2 /home2
    mount: you must specify the filesystem type

    So I try specifying a files system type and I get this.

    root@APCM8:/jrwarner> mount -t ext3 /dev/sda2 /home2
    mount: wrong fs type, bad option, bad superblock on /dev/sda2,
    missing codepage or helper program, or other error
    (aren't you trying to mount an extended partition,
    instead of some logical partition inside?)
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    Any idea on what I may be doing wrong or is my hard drive just messed up?

    Thanks.

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,754
    aren't you trying to mount an extended partition,
    instead of some logical partition inside?
    It's telling you the problem. You can't mount an extended partition. There should be logical partitions created within the extended.

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3

    Thumbs down

    So how do you go about mounting the logical partitions then?

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,754
    Code:
    Disk /dev/sda: 80.0 GB, 80026361856 bytes
    16 heads, 63 sectors/track, 155061 cylinders
    Units = cylinders of 1008 * 512 = 516096 bytes
    Disk identifier: 0x11209cdd
    
    Device Boot Start End Blocks Id System
    /dev/sda1 1 2081 1048792+ 82 Linux swap / Solaris
    /dev/sda2 * 2082 155061 77101920 85 Linux extended
    Fdisk says you don't have any. You have a primary marked as swap, and an extended. Logical's would be listed as sda5, sda6, etc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •