Hello, I created a dedicated grub partition when I set up my partitions and installed a few distros. I just tried to install a more recent up-to-date distro and something went wrong so now the grub partition is not taking over the boot loader.

The distro's grub is handling it 100%. Did I install that distro's grub to the MBR or something? I'm not sure what's wrong exactly but I want to restore the grub partition as before.

I have notes and I know which drive partition is assigned to which distro (sdaN etc.) but I cannot figure out what to do now.

I've tried some grub commands but none have worked. There's an error message or it's like my drive isn't even there.

I haven't had to do anything with grub for a while so I guess I didn't learn this stuff as well as I thought.

Does anyone recognize what the problem is and how to fix it?

My grub partition is on sda5 for e.g. and the distro was installed on sda9.

I thought I only had to install (Kubuntu's grub) onto the root partition of where it was installed.

Maybe my first mistake was installing one of the -buntus!