Find the answer to your Linux question:
Results 1 to 7 of 7
Okay i just installed the nvidia drivers for linux [b]sbin/init 3[/b[ and then sh NVIDIA-cr-ap and then edited the xorg.conf Now, when i go glxgears in terminal it puts out ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Sep 2003
    Location
    Brisbane, Australia
    Posts
    123

    Nvidia ti4200 - slow rendering FC2


    Okay i just installed the nvidia drivers for linux

    [b]sbin/init 3[/b[

    and then

    sh NVIDIA-cr-ap

    and then

    edited the xorg.conf

    Now, when i go glxgears in terminal it puts out 55fps or a 250 render.. whats up? on q3 on linux using a mx200 i got 50-60 fps online, and im only getting a similar ammount now, but with a far more extreme card.

    :C anyone help please? are there other things in the xorg.conf other then remove the couple of lines and ad "nvidia" ? or is there anything else? also i installed the NFORCE drivers... would that kill anything? that was mostly the sound card part of the chipset rather then anything to do with the video adapter...
    /skythra

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496

    Re: Nvidia ti4200 - slow rendering FC2

    Please post your complete computer specs so we can better help you. I've used a Geforce 4 ti4200 in FC2 and had wonderful results. It might also be good if you posted the very first section and the "Display" section of your Xorg.conf.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Newbie
    Join Date
    Sep 2003
    Location
    Brisbane, Australia
    Posts
    123
    Athlon XP 2600+ (1.93ghz)
    Gf4 ti4200 (64mb vivo version)
    40gig seagate 7200(isa)
    1280mb pc2700 (ddr 333) [just blew the PSU of my other box and so stole the ram and its HDD to try fedora on this PC with good specs)
    a7n400-x (asus board w/ nforce2 chipset)


    I have a feeling it could be the driver for the chipset i screwed.. but the config ill post:


    xorg.conf
    Code:
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    
    # RgbPath is the location of the RGB database.  Note, this is the name of the 
    # file minus the extension (like ".txt" or ".db").  There is normally
    # no need to change the default.
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    	RgbPath      "/usr/X11R6/lib/X11/rgb"
    	FontPath     "unix/:7100"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	Load  "extmod"
    	Load  "fbdevhw"
    	Load  "glx"
    	Load  "record"
    	Load  "freetype"
    	Load  "type1"
    EndSection
    
    Section "InputDevice"
    
    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    #	Option	"Xleds"		"1 2 3"
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    #	Option	"XkbDisable"
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults).  For example, for a non-U.S.
    # keyboard, you will probably want to use:
    #	Option	"XkbModel"	"pc102"
    # If you have a US Microsoft Natural keyboard, you can use:
    #	Option	"XkbModel"	"microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    #	Option	"XkbLayout"	"de"
    # or:
    #	Option	"XkbLayout"	"de"
    #	Option	"XkbVariant"	"nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    #	Option	"XkbOptions"	"ctrl:swapcaps"
    # Or if you just want both to be control, use:
    #	Option	"XkbOptions"	"ctrl:nocaps"
    #
    	Identifier  "Keyboard0"
    	Driver      "keyboard"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "yes"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "SyncMaster"
    	DisplaySize  300	230
    	HorizSync    30.0 - 60.0
    	VertRefresh  56.0 - 75.0
    	Option	    "dpms"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "nvidia"
    	VendorName  "Videocard vendor"
    	BoardName   "NVIDIA GeForce 4 ti4200"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        0
    	Mode         0666
    EndSection
    (also on a personal note, you really dont need to quote my entire post when replying, im pretty sure everyone knows who you are talking to and what about =p.)

    edit: i probably dont mean isa hdd.
    /skythra

  4. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Yeah, I was wondering about the HDD. With a relatively new Asus board you probably mean IDE. From what I can tell your Xorg.conf is correct. I've had issues installing the Nvidia nforce Linux drivers before, however, so I wouldn't be at all suprised if that's your problem. Uninstalling them could be tricky, and I've never done it myself. If you're not terribly worried about losing anything, you could always reinstall your distro and only install the display drivers, not the nforce ones.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  5. #5
    Linux Newbie
    Join Date
    Sep 2003
    Location
    Brisbane, Australia
    Posts
    123
    Yeah that was going to be my next step... but just like my old windows days, i dont want to because

    a) i have alot of programs all working all really well.
    namely just cedega.. so... off i go to format
    /skythra

  6. #6
    Linux Newbie
    Join Date
    Sep 2003
    Location
    Brisbane, Australia
    Posts
    123
    Total reinstall of FC2 and i now get 16000fps in 5 seconds in glxtestthingwhatever... thats like a few thousand frames every second and exactly what i was hoping for.

    The lesson probably is: dont install the nforce drivers :C
    /skythra

  7. #7
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    I had that same problem with the nForce drivers:
    they break everything untill you uninstall them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •