Find the answer to your Linux question:
Results 1 to 3 of 3
Hey all, For the past few months I have tried several times to manage my media on my iPod nano 4th gen through Rhythmbox and a couple other apps, however ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    15

    iPod nano 4th gen support


    Hey all,

    For the past few months I have tried several times to manage my media on my iPod nano 4th gen through Rhythmbox and a couple other apps, however most would not recognize it or even work. Rhythmbox did recognize it and access the DB file in my nano, however upon ejecting my iPod I found that the DB file had been corrupted therefore leaving me no way to listen to my songs on my iPod. As most may know, the new 4th gen and 5th gen iPods have a new DB setup which is easily corrupted and can not be used with most Linux media players. One of my friends was able to transfer songs via Rhythmbox, however he only achieved this by formatting his iPod through linux, instead of Windows or Mac, which I have already used Windows for

    Now for my question. Has anyone been able to, or known anyone that has been able to connect and transfer their songs and other media to their iPod nano 4th gen on linux without a corrupted DB file? And if so what tools or program(s) did they use to do this?

    For reference I am running Fedora 10 with a GNOME desktop environment.

    Thanks to anyone that can help!

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I'm running a Classic which has the new hashing "feature". I have no problem transferring at all using Amarok or GTKPod (frontend to libgpod, which I think Rhythmbox uses anyway). I know there is an option in GTKPod to rebuild your system folders on the iPod. Have you tried that?

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    15
    Thank you for you info. I looked in GTKpod and the only options I could find that matched that description were 'Check System Folders' and 'Create System Folder'. Neither of which did anything of use. And, sadly, upon ejecting it, there was the dreadful "0 songs" message again >.< So, I just decided to try completely reformatting and running it through Fedora. I will tell you how it worked in a little while.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •