Find the answer to your Linux question:
Results 1 to 5 of 5
I'm using Suse with a VM and there was a blackout when I was using the VM. Now I'm trying to start it and it says "Cannot open the disk ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    4

    [SOLVED] Question about (un)locking


    I'm using Suse with a VM and there was a blackout when I was using the VM. Now I'm trying to start it and it says

    "Cannot open the disk '/home/me/VM/WindowsXP-ORIGINAL/Windows XP Professional-000001.vmdk' or one of the snapshot disks it depends on. Reason: Failed to lock the file."

    I tried taking a snapshot in case I could manage to get it work, but now the error is:

    "Unable to access a file since it is locked. [standard] WindowsXP-ORIGINAL/Windows XP Professional.vmx"

    Anyone knows what can I do to fix it? Thanks in advance.

    EDIT: Maybe it couldn't lock the file in the first place because it was already locked, that's why it can't read the file to take the snapshot. But now the question is, how do I unlock it?

  2. #2
    Just Joined!
    Join Date
    May 2009
    Posts
    4
    Thanks a lot for all your answers

    I've managed to get it with chown. The problem is, I'm too lazy to change the owner of all files in the folder one by one, so is there any way to change them all at once?

    EDIT: Actually chmodding was enough xD

    EDIT2: No, it wasn't

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and welcome.
    Try chmod -R /path/to/chown
    Use the official man pages included with Linux, open a terminal window and issue this command
    Code:
    man chmod
    to find out more about man pages, read the official man page on that too.
    Code:
    man man
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2009
    Posts
    4
    I knew about chmod even before I started using Linux (FTP and stuff...) and it doesn't work. Not even with 777.

    I managed to get it work with the 000001.vmdk, but I can't get it to work with 000003... Don't know why.

    EDIT: I had it to 770, but it doesn't even work with 777. So weird...

    EDIT 2: I've also managed to get past (many zeros)3.wmdk and I don't even know how I've done it xD Now I'm gonna try to get past 4.

  6. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    4
    Seems it was problem of the VM, not the files. I've restarted it manually, which was a pain in the ass but works great.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •