Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all. I am tinkering with an HP LaserJet 4100 mfp with the hard drive add-in card . The drive on the card is a standard 40GB laptop IDE drive, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    2

    How to mount VENIX filesystem in Knoppix?


    Hi all. I am tinkering with an HP LaserJet 4100 mfp with the hard drive add-in card . The drive on the card is a standard 40GB laptop IDE drive, but when I connect it to my Windows machine and run a partition program (2 different ones so far - EAZEUS and Partition Manager), they identify it as partition type 0x40 Venix-80286. When I boot with my Knoppix DVD, fdisk agrees, but QTParted doesn't know what to make of it. I'm a bit rusty in Linux. How, if at all, do I mount the disk and read what's on it?

    The commands I have tried are (I know xenix is not venix, but I just tried xenix because I remembered it):

    mount -t xenix /dev/hda1 /hp
    REPLY= mount: unknown filesystem type 'xenix'

    mount -t coherent /dev/hda1 /hp
    REPLY= mount: unknown filesystem type 'coherent'

    mount -t sysv /dev/hda1 /hp
    REPLY= mount: wrong fs type, bad option, bad superblock on /dev/hda1
    missing codepage or other error

    I posted this on the Unix.com forums but no-one bit on it.

    TIA
    Yappi

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,173
    The venix operating system was a sysv-based pc unix system. Have you tried using mount without the -t type option? I don't know if the standard Linux disc driver will handle it or not, but it's worth trying. I've read where Linux is supposed to support the venix file system, but I haven't had the need to try.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    There's a kernel module for system V/xenix/coherent support. I am not sure if it will work for that partition, but you might want to try it.

    The fs type to use in mount would be "sysv", provided that your kernel has been compiled with that module.

    If it doesn't mount you could try to fsck it, provided that fsck has support for such fs (which I don't know at all). In any case, before doing so a backup is mandatory. I could very well blow up all the data.

  4. #4
    Just Joined!
    Join Date
    Jun 2009
    Posts
    2
    I'll try both Rubberman's and i92guboj's suggestions and get back. If I mess the disk up, no worries, since I can pop it back into the printer, access a service menu, and reformat it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •