Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Is there any way to disable a specific ACPI (component, event? I don't know)? Would there be a way to disable ACPI Thermal Zone, for instance. Could it cause any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Banned
    Join Date
    Jun 2009
    Posts
    68

    ACPI Question


    Is there any way to disable a specific ACPI (component, event? I don't know)? Would there be a way to disable ACPI Thermal Zone, for instance. Could it cause any problems? When compiling the kernel, could you leave thermal zone unchecked?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    Why would you want to do this? In any case, the thermal zone is to keep track of system overheating and can warn you when that happens, so you can shut down the system (manually or automatically) or throttle back the CPU speed in order to keep the system from becoming totally fried.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Banned
    Join Date
    Jun 2009
    Posts
    68
    I would want to do it because of the errors and exceptions I get. When using Ubuntu it's not so bad. When using Gentoo it's much worse. When using Fedora it's so bad I'll have thousands and thousands and thousands of lines of errors and exceptions to do with thermal. I've used Fedora and not even had the computer on for very long and already been up to around 150,000 lines of messages, pretty much pure errors. I posted a question about it in Redhat / Fedora Linux Help. It's just constant floods of messages in a few different log files. When compiling the Gentoo kernel, under ACPI ... support I saw the thermal zone as a separate listing and wondered if I could leave that out if it would help.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    Well, if you are convinced that your system isn't turning into a microwave oven, then try to disable it. FWIW, the sensors could be malfunctioning, giving all these false readings.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Banned
    Join Date
    Jun 2009
    Posts
    68
    I tried installing things on linux - sensor/temperature monitoring software. It didn't work, I couldn't get it to display anything. Using Windows XP, it does work though. More importantly, it works in the BIOS also. When I start up and check the bios, I can check the fan speed/temperature and it's accurate and the same as it shows on Windows XP. I know it's functioning, but for some reason Linux is having a major problem with this. Using Ubuntu, it's so few messages it's not a big deal at all. Using Fedora (and I'd assume the same of Gentoo), the messages don't show up when the fan is on. When it gets hot and the fan comes on, the messages stop repeating until the fan goes back off again. I'm very confused by it, and I've googled for a long time and found nothing. I tried installing lm-sensors, and could not get temperature.

  6. #6
    Banned
    Join Date
    Jun 2009
    Posts
    68
    Is there any way to control the messages that are output to your logs, so that you can choose to not record specific messages? Assuming you know which messages they are, can you choose to not have those specific messages output into your logs constantly? These messages are not important to me. They have caused no real problems.

  7. #7
    Linux User vickey_20's Avatar
    Join Date
    Mar 2009
    Location
    Mumbai, India
    Posts
    493
    what does the directory
    /proc/acpi/thermal_zone
    contains???
    Only if I could understand the man pages
    Registered Linux user #492640
    OS: RHEL4,5 ,RH 9,Ubuntu

  8. #8
    Banned
    Join Date
    Jun 2009
    Posts
    68
    Nothing whatsoever.

  9. #9
    Linux User vickey_20's Avatar
    Join Date
    Mar 2009
    Location
    Mumbai, India
    Posts
    493
    if you want to get rid of the messages then why not consider uninstalling the acpi itself.
    Only if I could understand the man pages
    Registered Linux user #492640
    OS: RHEL4,5 ,RH 9,Ubuntu

  10. #10
    Banned
    Join Date
    Jun 2009
    Posts
    68
    I've used the acpi=off noacpi boot options, and received the exact same messages.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •