Find the answer to your Linux question:
Results 1 to 3 of 3
I have a dual boot system with several partitions. My windows partition is /dev/sda1 and my mint partition is /dev/sda5 Tonight I decided to hook my PC up to my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    76

    Unhappy [SOLVED] Trashed filesystem and grub


    I have a dual boot system with several partitions. My windows partition is /dev/sda1 and my mint partition is /dev/sda5

    Tonight I decided to hook my PC up to my main TV in order to watch movies on it, but right after the grub screen went to boot into linux, I noticed my keyboard wasnt plugged in so I flicked the power switch to the 'off' position before any of the bootup text appeared on the screen.

    Upon rebooting, X would not start -- warning me that the filesystem was read-only.

    So I ran "sudo fsck /dev/sda5"

    Well, it came up with a message saying that the ext4 journal was bad, and asked me to clear it (thus temporarily making it into an ext2 filesystem). I selected yes, then I ran fsck again.

    This time there were hundreds of errors. Missing inodes, bad symlinks, etc etc. Some of the errors were even illogical looking, like the folder ".." having errors.

    I just held the 'y' key on my keyboard hoping it would be over soon but the errors just kept coming. Eventually they stopped and fsck asked me to reboot. So I typed in "sudo shutdown now" and "sudo reboot" but they werent working.

    I hard rebooted and after posting I was greeted to a black screen

    "Error 15" was the sum of it.

    As a result, I booted into my "Linux Mint 7" LiveCD and tried to run fsck, but fsck gave me a message about a bad superblock, or wrong FS type.

    I opened gparted to see what was up, and according to gparted, "/dev/sda5" was an "unknown filesystem type"

    So, from the liveCD, I installed and ran 'sudo testdisk /dev/sda" and it recognized /dev/sda5 as an ext4 partition, so I wrote that configuration to disk -- and testdisk warned me that the configuration wouldnt take effect until the system was rebooted.

    I rebooted, and nothing happened. So I ran testdisk again, looked inside of the partition and there were no other folders apart from lost+found.

    What should I do from here?

  2. #2
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    It looks like everything is lost. You will have to re-install.
    Registered Linux User #420832

  3. #3
    Just Joined!
    Join Date
    Aug 2009
    Posts
    76
    Yes, I thought this might be the case. Luckily, most of my files were stored on a big 'shared files' partition that I shared with my windows install (symlinked folders: music, pictures, videos, downloads, etc...) just in case situations like an OS getting trashed ever happened.

    Now that I know theres nothing I can do, i'll just go ahead with the reinstall, since I'm already starting to miss my linux environment.

    domo, arigatou

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •