Find the answer to your Linux question:
Results 1 to 4 of 4
Hi there, For some unkown reason my su password is getting rejected. it is the right password, there are no ssh conections or anything. I get authentication failure. tried sudo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    10

    [SOLVED] SU password failure [debian]!!


    Hi there,
    For some unkown reason my su password is getting rejected. it is the right password, there are no ssh conections or anything. I get authentication failure.
    tried sudo su, but my user is not a 'sudoer'.
    Tried to look at /var/log/syslog but authentication needed so no help as to why this happened.

    Any help would be great. plus an explanation would also help.

    tried exec sudo su, and after entering a correct password it just kicks me out of terminal

  2. #2
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,201
    Try This Maybe.

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Posts
    10
    Thanks for that. Trying to boot into single user from grub and it kicks me into the gnome-login gui.
    Same when i make a boot: Linux init=/bin/bash option
    Any Idea's?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2009
    Posts
    10
    Hi there,
    got it fixed by using recoverycd and mounting then chroot-ing.
    After getting back in and looking at auth log I can see I got hacked on my ssh, using a PAM exploit.
    oh well guess my fault for leaving it open. the computers only been up a week so no real data to steal, the guy just got a good look at my coursework - poor sod!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •