Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I have got arch Linux dual booting with Win XP on my laptop. I have been getting a filesystem check error since yesterday and am unable to start Arch. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2009
    Posts
    20

    [SOLVED] Filesystem check failed


    Hi,
    I have got arch Linux dual booting with Win XP on my laptop.
    I have been getting a filesystem check error since yesterday and am unable to start Arch. Upon googling and searching the arch fora, I came upon some advice which I tried which has not worked yet. Hence the new post...

    Basically, I was attempting to print something off and accidentally chose a printer that was not connected to my laptop. After half a minute or so, it repeatedly started giving me notifications that the printer was not connected...in excess of 200 messages that the printer was not working which continued to pop up despite me canceling the print job. The whole system got really sluggish (for the first time in the last year) and I had to restart the laptop upon which the boot messages appear.
    It gets to the point where its loading the various filesystems. It mounts root and says it fine. Then it says





    Code:
    /dev/sda3: clean, 171642/915712 files, 1837167/3662820 blocks
    /dev/sda2 is mounted.  /dev/sda5 is mounted.
    
    Filesystem check failed.
    Please repair manually and reboot. Note that the root file system is currently mounted readonly. To remount it read-write type: mount -n -o remount  ,rw /
    When you exit the maintenance shell the system will reboot automatically.
    In my system,
    /dev/sda1 is Windows XP
    /dev/sda3 is root
    /dev/sda2 is boot
    /dev/sda5 is home

    I tried fsck which tells me that home and boot are still mounted.
    So I booted up using an Ubuntu Live CD and checked and repaired each file system which it successfully did. Upon rebooting into Arch, I am getting the same message.
    I can access all the partitions via the Ubuntu Live CD.
    I have not installed anything new and had upgraded the whole system a few days before the problem started.
    Not sure where to go from here.
    Any help, please
    Thanks

    Samsom

  2. #2
    Just Joined!
    Join Date
    Feb 2009
    Posts
    20
    Fixed the problem.
    The /dev/sda2 and /dev/sda5 were being mounted in the wrong place.
    Instead of being mounted in /home and /boot as per /etc/fstab, they were being mounted in new directories in /media called /media/usbhd-sda2 and /media/usbhd-sda5. Upon deleting those folders, everything has gone back to normal.
    I have no idea how those new folders got created...but problem solved now.

    Samsom

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •