Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, I have an HP laptop with both Ubuntu 8.04 and Windows Vista installed on it. The other day I noticed I was running out of space in the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    2

    [SOLVED] Partition modification made Windows crash


    Hi all,

    I have an HP laptop with both Ubuntu 8.04 and Windows Vista installed on it.
    The other day I noticed I was running out of space in the main linux partition (the / partition, not the /home partition), so I decided to move some space from the Windows partition and move it to the linux one. I used a GParted Live CD to do that.
    My partitions are ordered as follows:
    1. Windows Vista partition (NTFS)
    2. Main linux partition / (ext3)
    3. Linux home partition /hom (ext3)
    4. HP RECOVERY (NTFS - I don't know what it is, it just comes with HP laptops that have Vista on them)

    So I shrank partition 1, and then "moved" partition 2 to enlarge it (GParted said everything was alright).
    After doing that, I went to my linux and everything seemed to be fine, I'm also quite sure I had access to my Windows partition as always. But today I tried to start my Windows and it just got stuck on the "loading" stage (that screen that says "Microsoft Corporation" and has a green loading bar). So I shut the computer down manually (by holding the power button for a few seconds). After doing that a couple of time, I went to my linux, which worked just fine, but I was not able to go to the Windows partition. You can see how GParted looks now for my computer:
    img682.mageshack.us/img682/1122/gpartedo.png
    (I can't give a direct link sine I'm a new user)
    As you can see, the first partition (/dev/sda1), which is supposed to be the Windows partition, is not mounted and the system doesn't seem to be able to read it properly. Here is my attempt to mount it manually:
    Code:
    sudo mount /dev/sda1 /windows/
    
    $LogFile indicates unclean shutdown (0, 0)
    
    Failed to mount '/dev/sda1': Operation not supported
    
    Mount is denied because NTFS is marked to be in use. Choose one action:
    
    
    
    Choice 1: If you have Windows then disconnect the external devices by
    
              clicking on the 'Safely Remove Hardware' icon in the Windows
    
              taskbar then shutdown Windows cleanly.
    
    
    
    Choice 2: If you don't have Windows then you can use the 'force' option for
    
              your own responsibility. For example type on the command line:
    
    
    
                mount -t ntfs-3g /dev/sda1 /windows/ -o force
    
    
    
        Or add the option to the relevant row in the /etc/fstab file:
    
    
    
                /dev/sda1 /windows/ ntfs-3g force 0 0
    I truly don't understand why this happened, and what I'm supposed to do now. I have some very important stuff on my Windows (mainly pictures), that I just don't have access to. Also I did pay for this Vista (came with the laptop) so I'd really really be glad if it worked.
    Can anyone please help me?

    Thanks a lot!
    Last edited by Omri; 02-09-2010 at 03:01 PM. Reason: solved

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello and Welcome!

    I've no idea what type of repair utilities come on a Windows disk, but you'll probably need to use those for some repair work.
    While rare, issues like this can arise any time you re-size a partition or mess with the file-systems. Do you happen to have backup copies of your data?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,175
    Shrinking a live partition as you did is fraught with danger. Before you do so, you need to defrag the partition so that there is empty space at the end of the partition to "steal". if you try to shrink a partition, and that space is occupied with important stuff, all bets are off. I don't know if this is your problem, but it may be. Good luck.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    2
    I was advised to use the command ntfsfix that comes with the package ntfsprogs; it made Windows perform chkdisk automatically the next time I ran it, and now everything works again.

    Thanks guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •