Find the answer to your Linux question:
Results 1 to 10 of 10
Hey guys! Erm... I'm the guy, whos boss made him setup a linux server I have Ubuntu 9.10 setup... for the only purpose to be a public FTP server (don't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4

    [SOLVED] Boot automaticaly


    Hey guys!

    Erm... I'm the guy, whos boss made him setup a linux server

    I have Ubuntu 9.10 setup... for the only purpose to be a public FTP server (don't ask)
    Anyways....

    I'm having the following issue:
    Whenever I reboot the computer I get a list with kernels to choose from. Basicly I always choose the latest, but is there a way to get rid of that menu and just boot the latest kernel by default? I mean... if there's a power crash in the neighbourhood the computer will start, but won't boot and will be useless...

    Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Feb 2010
    Posts
    18
    Hi,

    tipically grub runs the last kernel after a default timeout.
    If you set the timeout to 1 (sec) it will start almost immediatly!

    bye
    Last edited by oz; 02-17-2010 at 09:56 PM. Reason: removed spam

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4
    Well... that's kind of my problem actually - there is no timeout... it just waits for a choice... could you please tell me how to change that?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    18
    Hi,

    by default ubuntu should have a timeout: this is my file

    /etc/default/grub

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="10"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    My system has a 10sec timeout: check if you have a different value (I think -1 stands for wait forever)

    bye
    Last edited by oz; 02-17-2010 at 09:55 PM. Reason: removed spam

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    My system has a 10sec timeout: check if you have a different value (I think -1 stands for wait forever)
    -1 does mean it waits for user input.

    https://help.ubuntu.com/community/Grub2

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    To be on safer side, set GRUB_TIMEOUT="10" value to "2". Make sure to execute sudo update-grub command to generate new grub.cfg file after editing /etc/default/grub file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773
    Or you edit the file /boot/grub/menu.lst directly:
    Code:
    sudo nano /boot/grub/menu.lst

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by Kloschüssel View Post
    Or you edit the file /boot/grub/menu.lst directly:
    Code:
    sudo nano /boot/grub/menu.lst
    Hi and Welcome !

    Ubuntu 9.10 has GRUB2 and it doesn't uses menu.lst file now. Conf files of GRUB2 are different form its earlier version, GRUB.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773

    Lightbulb

    Quote Originally Posted by devils casper View Post
    Hi and Welcome !

    Ubuntu 9.10 has GRUB2 and it doesn't uses menu.lst file now. Conf files of GRUB2 are different form its earlier version, GRUB.
    And there all shall bow before the superior knowledge of the master. I moved just last week to ubuntu because debian gets slightly cranky with updates/upgrades and am not yet that familiar with it's ways and tons of new packages. Thanks for the hint.

  11. #10
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4
    Quote Originally Posted by giammy View Post
    Hi,

    by default ubuntu should have a timeout: this is my file

    /etc/default/grub

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="10"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    My system has a 10sec timeout: check if you have a different value (I think -1 stands for wait forever)

    bye

    --
    gianluca moro --- cloudusb.net

    Hey guys!

    Setting GRUB_TIMEOUT="2" solved my problem, so... thanks a lot! And keep up the good work!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •