Find the answer to your Linux question:
Results 1 to 3 of 3
Using Debian Lenny I have a NTFS filesystem on which I have xp installed. I mounted it on /mnt/xp I can cd into it, but I can't mkdir or save ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    169

    [SOLVED] can't mkdir or save inside directory


    Using Debian Lenny
    I have a NTFS filesystem on which I have xp installed.
    I mounted it on /mnt/xp
    I can cd into it, but I can't mkdir or save anything in this dir or farther
    down the filesystem. I tried doing this as root and these are the
    ownership and permissions:
    Debian:/mnt# ls -ld /mnt/xp
    drwxr-xr-x 1 root root 4096 2010-02-07 18:19 /mnt/xp
    Debian:/mnt# ls -ld /mnt/xp/Documents\ and\ Settings/
    drwx------ 1 root root 4096 2010-02-03 20:23 /mnt/xp/Documents and Settings/

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Debian doesn't support NTFS write access out of box.
    Have you installed ntfs-3g package? Mount NTFS partitions using ntfs-3g to enable write access.

    Code:
    su -
    apt-get install ntfs-3g
    Mount partition ( or edit /etc/fstab )
    Code:
    su -
    mount -t ntfs-3g  /dev/<partition>  /mnt/xp -o defaults,umask=0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    169
    Thanks for the help.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •