Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all, I'm trying to run a redhat 9 server on an old computer of mine. I'm an intermediate at linux, but this thing has me lost and confuzed. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Canada
    Posts
    3

    GUI issue (I think...)


    Hi all, I'm trying to run a redhat 9 server on an old computer of mine. I'm an intermediate at linux, but this thing has me lost and confuzed.

    I can install, configure, and update it just fine, but I'm one of those who seems to need a GUI since I grew up with Windows. The first few reboots seem to work perfectly, then for no apparent reason, one reboot will fail to load the GUI login and every 7 seconds or so it will switch back to text and vice versa continuously. After that reboot, I can't access the system at all (even using the created boot-disk).

    I've tried several re-installs of the OS (complete, reformat and everything), but every time I run into this same problem. At first I thought it was the updates I was doing, but after a non-update install, it still did it to me, so I'm completely lost.

    specs are:
    -80mb of RAM
    -i586 pentium 179 mhz
    -8mb of video RAM

    Anyway, if someone could shed some blatantly obvious light on this it would be much appreciated.

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    India
    Posts
    46
    Does booting into the terminal prompt and starting X manually (by startx) give the same problem?
    (You can try that by modifying the /etc/inittab file, line 18, change id:5:initdefault: to id:3:initdefault:, reboot)
    Also try starting X (type xinit) and starting KDE or GNOME manually (type startkde and gnome-session respectively) to see whether the problem is with the Xserver configuration, or the GNOME and KDE packages. The installation may not be proper as you might be installing from the same (maybe defective) cd everytime.
    If the problem is with the Xserver configuration, type "XFree86 -configure" to generate a new configuration file.

  3. #3
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    it sounds like your X config is borked.. most likely incorrect monitor settings or some such is causing X to crash, and the init tries to respawn it and it dies again.. and this continues in a vicious cycle...

    so, the first thing you need to do is make ABSOLUTELY sure that you know what your monitor's vert refresh and horiz sync rates are... don't just select a model from their list... input the values by hand.. (you can find them in the monitor's manual or on the web.. Google is great for finding that info)...
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  4. #4
    Linux User benjamin20's Avatar
    Join Date
    Oct 2004
    Location
    jacksonville beach FL
    Posts
    317
    google is greatfr finding ANY info
    nVidia G-Force 6600GT (bfg) pci-e: amd 64 2000+ (939): 1024 corsair ram: 2X 80gb seagate harddisk SATA: plextor cd/dvd-read/write cdrom SATA

  5. #5
    Just Joined!
    Join Date
    Oct 2004
    Location
    Canada
    Posts
    3
    Ok, I managed to rescue it from the cycle (which I overestimated, it's actually a 2 second break between restart attempts). I changed the /etc/inittab file to start in text mode, so I now have a command line.

    I tried the "startx" command and it still wouldn't start. It gave me the same problem with the following error message:


    Fatal server error:
    could not open default font 'fixed'

    ...(instructions for error reporting)

    XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"


    I think it's quite possible that the problem is the monitor's refresh rates (as I just chose an unprobed monitor), do you know where the file can be found where I can change that?

    Also, I don't think that it's the CDs, becuase I was running a newer computer off of those CDs for a while before I switched to Fedora.

  6. #6
    Just Joined!
    Join Date
    Aug 2004
    Location
    India
    Posts
    46
    As i said, type "XFree86 -configure" to generate a new configuration file automatically. If you want to edit the file manually, it's usually /etc/X11/XF86Config

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It sounds to me as if there's something wrong with the font server. See if xfs is started, and if it isn't, see if it works if you start it:
    Code:
    service xfs status
    service xfs start

  8. #8
    Just Joined!
    Join Date
    Oct 2004
    Location
    Canada
    Posts
    3
    peachy, it worked perfectly, thank you all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •