Find the answer to your Linux question:
Results 1 to 4 of 4
hi i have puppy linux and im trying to compile gtk+-2.18.0 but when i ./configure it, it configures for a little bit then: checking for BASE_DEPENDENCIES... configure: error: Package requirements ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    7

    help compiling gtk+


    hi i have puppy linux and im trying to compile gtk+-2.18.0 but when i ./configure it, it configures for a little bit then:

    checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.21.3 atk >= 1.13.0 pango >= 1.20 cairo >= 1.6) were not met:

    Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.18.3

    consider adjusting the PKG_CONFIG_PATH environment cariable if you installed sftware in a non-standard prefix.

    alternatively, you may set te environment variable BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
    see the pkg-config man page for more details.


    but the thing is, is that i know i installed glib-2.22.0 and im pretty sure it installed correctly. so i guess my question is, does anyone know if puppy comes with glib-2.18.3? and if it does where can i find it to change it? and if it doesnt, how would i locate the version of glib that i have now and change it to the other one i installed? or can i change the ./configure command to point it in the right direction? please help! thanks and all feedback is much appreciated.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,530
    So, are you running a 32-bit, or is it a 64-bit OS? If 64-bit, perhaps you installed the 32-bit version of glib-2.22.0.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    7
    Quote Originally Posted by Rubberman View Post
    So, are you running a 32-bit, or is it a 64-bit OS? If 64-bit, perhaps you installed the 32-bit version of glib-2.22.0.
    nope im running a 32-bit

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,530
    So, when you installed it, did it go into /usr/lib, or /usr/local/lib? If it was installed into /usr/local/lib, then you need to change the PKC_CONFIG_PATH variable, or specify where it is found in one of the configure options (run ./configure --help for information).
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •